Incoming call drop after 6 seconds after freepbx os activation

Hi, before moving on to freepbx I tried to set up a test machine that I didn’t activate, everything seemed to be fine so I made a backup and installed freepbx os 15 on the final machine, activated it, did the updates and did a restore with the backup made previously. At this point the trunk was connected but after 6 seconds the incoming calls dropped without hearing any audio. I tried to re-install freepbx os and not activate it, I did the restore and the incoming calls worked. I then tried to activate the system and again in incoming calls I had 6 seconds of silence and the call was closed. In the asterisk log I have these messages:

30013 [2021-11-02 13:52:39] WARNING[2764] chan_sip.c: Retransmission timeout reached on transmission [email protected] for seqno 1 (Critical Response) – See
30014 Packet timed out after 6399ms with no response
30015 [2021-11-02 13:52:39] WARNING[2764] chan_sip.c: Hanging up call [email protected] - no reply to our critical packet (see

This is a nat problem. Did you read the wiki article mentioned in your log output above?

Yes I have read, but probably given my inexperience I have not solved it.
Excluding firewall problems (the pbx is behind an opnsense firewall) since before recording the incoming calls work regularly, I checked within freepbx, on asterisk sip settings the external ip address is set correctly, the same for the local network ( I tried to add the network in the trusted networks but nothing has changed.
I have enabled the sip log and I have received this log, but I cannot understand what the problem is. I apologize but as already said my inexperience is driving me around in circles.

log file

You are using chan_sip on a system that also has chan_pjsip installed. As chan_sip is deprecated, the first thing to do would be to move to pure chan_pjsip. If there proves to be a problem in chan_sip, it will, almost certainly, not be fixed.

There seems to be a complex arrangement of proxies here. Please explain the significance of the 83., 62., and 78.* addresses, in your network topology.

Please confirm that your public address is the 78.* one and your public port is 5160, and that you have port forwarding for 5160, to 5160.

Yes, my pubblic ip is 78*, 83* is ip of sip provider, how i can move from chan_sip to chan_pjsip?
I confirm that I forwarded 5160 port to 5160 internal port

83 is the provider’s proxy. The exact situation with the provider is confused, but they seem to be 62, although their call-id suggests they are 10.

You are sending OK to 83, with a via for 62, and a contact for 78:5160. That all looks OK on the Asterisk side, but you are not getting an ACK back from the provider.

Ok I don’t know why but after a firewall reboot all is ok, thanks for your support

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.