Incoming audio fails Overnight

Hello Everyone,

I have been working to find a solution to an issue I have been having for some time now.

I have installed AsteriskNOW with FreePBX 2.10. Everything is working great function wise. I have everything configured perfectly and the system is ready to go live in our office.

However, the thing holding me back from making the system live is after about a day, I do not have any incoming audio on my POTS lines. Once I restart the server, it will work again. I have tried logging the Asterisk console to see if some event is triggering, but noting happens at all during the time where it stops working.

Maybe there is some other log I can look at to find out whats going on?

As for hardware, im running an IBM x346 server with 5 disk Raid 5EE, 4GB of ram and a TDM2400 with 3 - 4ch FXO cards. I tried different FXO cards and that did not make a difference.

Any help would be very much appreciated.


I have re-installed the system and reconfigured everything. I have only installed the modules I need and nothing else. I kept everything as simple as possible. This was Friday afternoon.

Well today is Sunday, and I do not have incoming audio any more. I have narrowed things down a little, but not exactly sure where to go from here.

When an outside call comes in, the extension ring, but the caller cannot be heard, but the caller can hear the person that answered.

In testing, I set up incoming calls to be sent to my cell over an outgoing line. This results in NO audio.

This leads me to think its something to do directly with the TDM2400 card and not asterisk itself. When I restart the server, everything starts working again.

Another update, if I stop amportal and restart the dahdi service then restart amportal, everything works again. Anybody have a suggestion what would be causing something like this, and where I can look to fix it?


This sounds like a nat issue, but before chasing the problem, if I were you, in the interests of future maintenance I would load the freepbx distro with asterisk 10 and Centos 6.2 and take it from there. Digium have not been good at maintaining Asterisk Now whereas Tony Lewis has done a meticulous job maintaing the Freepbx Distro.

Hello Stonet,

Where can I find this new version of asterisk now? I wanted to run Centos 6.2, but was unable to get Asterisk to build on it.

I don’t think this is a NAT issue as it is intermittent. It starts after the system being on for about 12 hours and I found out today that I can correct it by reloading dahdi. When when I call into the system and have it call my cell phone so it doesn’t go to any SIP extensions, I do not get any audio.


It’s not a version of Asterisk Now, it’s the official FreePBX distro.

It will also intall the latest DAHDI drivers for you.

I would make sure you have all power management turned off in your system. Sounds like the motherboard may be putting the PCI bus to sleep.

Look for the Distro tab at the top of this page.

Hello SkykingOH,

I checked the power management and there doesnt appear to be any on this machine. This is an IBM x346 Server. Not sure if it matters but IRQ for the card is set to 3.

I seem to have the same problem but I have no audio even after I

amportal stop
service dahdi start
service dahdi status (all comes back OK)
amportal start

Everything is reporting OK in the Asterisk CLI…


~scratches head~

OK, So I found the problem.

As it turns out, the IBM x346 that I was using for the server shares the full size PCI bus with a bunch of other devices. This cant be changed and changing slots, doesn’t help because its still the same bus. This was causing missed interrupts and eventually the driver would shut down the card. Restarting dahdi reconnected and it continued to work. I have since moved to a different server. An IBM x360.