Incom ICW-1000G

I just picked up a couple of Incom ICW-1000G WIFI phones. I have the commercial endpoint manager. For the life of me I can not get these phones to provision. I have several other brands (aastra, polycom, grandstream, etc), and they all provision vie the endpoint manager without an issue.

I can see on the phone that the provisioning server and port are being correctly assigned via DHCP option 66. I’ve verified that an e1_MACADDRESS.ini file is being created.

At this point I am at a loss. Anyone out there using this phone?

It seems to me like the phone tries to auto provision before wifi is established.

We’ve got one of these to try also as a potential replacement for the dect system.

We have yealink desk phones here that like boot option 66 in the format tftp://ipaddress

I’ve found that the incom wants it in the format of just the IP address (no tftp://) if that helps at all. I had to turn off the boot option 66 in the phone and put in the provision server manually.

On another note the phone is good, but rather annoying. When roaming across access points (we have 70 d-link waps managed by a clustered controller) the incom won’t reconnect if you walk into a black spot. You have to manually reconnect and some of the time it won’t connect properly. The other issue is that it doesn’t maintain contact with the freepbx system. It’s constantly being marked as lagged or unreachable. Whenever you make a call it works straight away, but when trying to call the incom it often doesnt ring.

I have solved your first problem in the past where old aastras and polycom’s wouldn’t play nice together. I used dnsmasq’s available services as a replacement for dhcp and tftp servers with a set of -U options to suit specific vendor mac addresses.

I just got a few of these phones myself for my company and I had the same issue where the phone would only call out. Had to open the port 5060 on our firewall and it started registering fine with the server and allowed traffic both ways. You might check your firewall and possible specific routing being done.

Thanks Ben, I thought that too but after creating a new SSID on the same VOIP vlan to bypass the router, we’re still having this issue. From time to time the handset is reachable, but for the most part it isn’t. Do you find that when you roam outside of wifi coverage it doesn’t automatically reconnect so you have to hit the connect button?

I haven’t experienced that yet. I use Ubiquiti UniFi UAP Wireless Access Points at our locations and just the typical DSL modem/router at home(don’t laugh, its temporary) and it connects to both automatically. I don’t have auto-provisioning on though. I manually set everything because some of these phones are in remote locations.

I did find the same thing of these phones liking IP address over domain names as you pointed out.

I was told that some PBX systems have a WiFi type setting that needs to be enabled. Not sure what it is specifically(I use Trixbox/Fonality), I didn’t have to do it on mine. But the people who I bought the phone from( warned me about that setting. Other than that, I am running out of ideas.

Could someone tell me where the IP for the PBX goes on this phone to get it to start making calls? I have the auth user and user the ext. #. I figured it was the sip proxy but that is not working. I try to make a call and it says registration failed. Could someone give me a run down of how they got their Incom 1000 to connect please? I would like to not use the provisioning server if possible.


If you are using the End Point Manager module in FreePBX, all you need to do is:
Go to the Phone’s Web Config Tool (http://ipaddressofphone:8080), pass the first user Web login, then the Setup login, the under the Configuration Tab, scroll to “Provision” and put your PBX URL and Request Mode there: