Incom 1000G cannot connect with commercial epm

I’m using FreePBX 13.0.192.18. I created a pjsip extension and increased max contacts to 2. I connected a yealink t48G and set it up in extensions under other. Set brand model template… Works fine. Next I set an incom 1000G. It picks up it’s config file because the phone extension is set on the phone screen. I cannot make a call however i get the following in the logs… any ideas?

[2017-10-18 13:10:10] NOTICE[3222]: chan_sip.c:28600 handle_request_register: Registration from '"hidden-430" <sip:[email protected]>' failed for '10.0.2.232:5061' - Wrong password 
[2017-10-18 13:10:10] NOTICE[3222]: chan_sip.c:28600 handle_request_register: Registration from '"hidden-430" <sip:[email protected]>' failed for '10.0.2.232:5061' - Wrong password

Your INCOM is tryign to register with the chan_sip port not the pjsip port.

I really don’t see what controls that.

In the basefile there is…

[SIP]
Local_Port=__line1sipPort__

Where does line1sipPort come from?

Create a new template and hardcode the value?

It pulls that from asterisk sip settings what you have defined their. it almost seems like the INCOM ignores the port and always sends to 5060 only and I bet you have chan_sip on 5060

Yeah I have chan_sip on 5060.

The phone config file has a setting for udp but the tcp port isn’t there. Is that ok?

[SIP]
Local_Port=5061

Due to the fact that those phones are listed as certified for freepbx can you take this to their support?

You would need to open a support ticket with our support team to investigate what’s going on.

Ok I can do that but will I be charged even if this isn’t found to be my fault? It doesn’t seem like I should have to pay to get incom to fix their bugs. Especially for “certified” phones.

Support tickets for Commercial module bugs don’t require credits.

Might be an incom bug not a commercial module bug (assuming there is a bug at all)

At any rate I created a ticket.

Here’s a tcpdump of the incom trying to register…

REGISTER sip:10.0.2.3 SIP/2.0
Via: SIP/2.0/UDP 10.0.2.232:5061;branch=z9hG4bK2054804485
From: "-430" <sip:[email protected]>;tag=333098112
To: "430" <sip:[email protected]>
Call-ID: [email protected]
CSeq: 1 REGISTER
Contact: <sip:[email protected]:5061>;expires=3600
Max-Forwards: 70
User-Agent: WPU-7800-v1.0.9
Allow: INVITE,SUBSCRIBE,MESSGE,OPTIONS,REFER,NOTIFY,ACK,BYE,CANCEL
Content-Length: 0

and the response…

15:39:56.125492 IP freepbx.rmtohio.com.sip > 10.0.2.232.sip-tls: SIP, length: 533
E`[email protected]
...
...........SIP/2.0 401 Unauthorized

Here’s the yealink, ( didn’t capture the response but it was OK)

......../J.REGISTER sip:10.0.2.3:5061 SIP/2.0
Via: SIP/2.0/UDP 10.0.2.202:5061;branch=z9hG4bK2172903039
From: "" <sip:[email protected]:5061>;tag=3448049511
To: "" <sip:[email protected]:5061>
Call-ID: [email protected]
CSeq: 1 REGISTER
Contact: <sip:[email protected]:5061>
Allow: INVITE, INFO, PRACK, ACK, BYE, CANCEL, OPTIONS, NOTIFY, REGISTER, SUBSCRIBE, REFER,     PUBLISH, UPDATE, MESSAGE
Max-Forwards: 70
User-Agent: Yealink SIP-T48G 35.81.0.110
Expires: 0
Allow-Events: talk,hold,conference,refer,check-sync
Content-Length: 0

The FROM and TO are missing the port on the incom. Is that the problem?

Support as we states can help. Something isn’t right and yes if the To has no port it would infer it’s sending to default SIP 5060. Hopefully the phone even supports defining the port to use. It might be a bug in our config but support can help you. If it’s not a bug on our side you will need to work with incom to get resolved.

Well I put in a ticket. Hopefully they will respond.