Inbound voip.ms


(Kappclark) #1

I am using Voip.ms. I can make outbound calls fine.

Inbound calls do not make it — I call the DID and it goes straight to voicemail. Voip.MS is registered as an endpoint.

Have inbound route set up as follows, sending calls to extension 400 (my deskphone)

I checked and re-checked voip.ms page … not sure why it only goes in one direction … do I need to create a second trunk for inbound ?


(ParaGuy) #2

I think you do normally need one for inbound and outbound. This guy shows a set up here: https://www.youtube.com/watch?v=Mu1OxktwURg


(Jared Busch) #3

Not ever.

I wrote this for FreePBX 13, using PJSIP. It is still correct.


(Jared Busch) #4

If it goes to voicemail, it is hitting your PBX.

Need logs.
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


#5

You do not need a second trunk.

VoIP.ms voicemail or FreePBX voicemail?

If the former:
Does anything appear in the Asterisk log on an attempted call? If so, post details.
If nothing in the Asterisk log, do the incoming INVITEs appear in sngrep? If so, you have a FreePBX firewall issue. If not, confirm that at VoIP.ms, the DID is routed to the correct sub-account and post details about your hardware router/firewall.

If the latter:
Confirm that you can call ext. 400 from another extension. Temporarily set the DID Number field of the Inbound Route to (blank) (will show as ANY) and report whether the call reaches the extension.


(Kappclark) #6

Sorry - the VM is at voip.ms…

Thx for pointers … Not sure I can address this right away - but it looks like the truth out there … Fathers day celebration has started… will look at this later…


#7

I only have one DID and use it for both inbound and outbound


(Dave Burgess) #8

No.

You have a DID for inbound and you use the outbound link with that DID as a Caller ID. It really never helps to think of the inbound and outbound legs of a SIP call process as “a line”.

Your inbound calling hits your PBX because your ITSP sent it to your box. The fact that is has your DID as the “destination” is a cool feature. Outbound calling can (depending on your settings and your ITSP) have literally any Caller ID in the world.


#9

Confirm thatin VOIP.MS DID Settings:
DID>Routing Settings>Main
Is set to “SIP/IAX” pointed at your Trunk "SIP/[Acc#]_TrunkName
Also, make sure that the DID is on the same POP as the Trunk. If not the inbound call will fail
Check on the FreePBX Trunk under “sip Settings” the Register String should have the same POP as the DID Setting in the VOIP.MS Portal

123456_TrunkName:secret@pop_name.voip.ms:5060

Where 123456 is the VOIP.MS Account number


(Kappclark) #10

Just got back home … thx for replies…and suggestions …

I reached out to Voip.ms, and they said to have calls routed to the main account, not the sub account. The sub account was not registered …

I did that in the admin portal of voip.ms, and inbound calling works.

Is a sub-account required all ? Somewhere I think I saw a post and a video saying you needed a sub account … but this seems to work fine with just the main account.


(Jared Busch) #11

You should always you a sub account for everything.

You can reset you sub account or lock it out or delete it easily in case of a compromise.


(Kappclark) #12

So a security measure ? But technically not a REQUIREMENT to run freepbx ?


(Jared Busch) #13

Correct, if you do registration. If you want IP Auth I think (been a while since I looked) you have to use a sub account.

Either way just do it.


(system) closed #14

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.