Inbound username mismatch

This is my first run using a Analog IP Gateway (Grandstream GXW-4014).

I’m able to call out using the trunk but inbound I get the following error’s.

My inbound route DID matches the incoming number, I’m not sure if I have the trunk details just not right, something in the gateway a mess (btw a analog gateway is not for the faint of hart) inbound route seems right. Any pointers here? I did a Google with error the message and could make heads or tails with what I found.

Thanks in advanced,


[2013-10-23 10:09:28] WARNING[1885][C-00000189]: chan_sip.c:16374 check_auth: username mismatch, have , digest has <> [2013-10-23 10:09:28] NOTICE[1885][C-00000189]: chan_sip.c:25282 handle_request_invite: Failed to authenticate device "TWIN CITIES,MN ";tag=62906cd2497

Trunk Details


Analog lines don’t do DID, you might have programmed the gateway to send some digits that could be used to route with.

If you are sending a username you need to add it to the trunk details. The fromuser or username directive may be appropriate. I suggest you familiarize yourself with all the SIP options:

I find this guide very useful.

Thanks Scott, great link, will read up and see what I can find

Well I got it to work by using “insecure-invite” in the peer details in lieu of “secret=xxxx”.

The issue seems to be setting a password in the Gateway, not sure what I got a mess but will keep digging into it.