Inbound RTP not recognised by FreePBX

Have installed FreePBX on RPi4 and banging my head trying to get inbound RTP recognised by the PBX.

Config consists of an RPi4 running PBX (Asterisk 16.9.0) with an internal network (no NATs) comprising around 6-10 phones (a mix of Grandstream, SNOM, and Gigaset). All connections using Chan_PJSIP stack. PSTN trunk made using ObiHai FXO gateway. All working satisfactorily on my legacy config running on a Dell tower with FreePBX 2.11 (using Chan_SIP).


  1. Try to use internal extension to leave voicemail - voicemail announcements heard, but voicemail not recorded. Wireshark trace confirms RTP is from PBX only - no RTP visible from extension.
  2. Try to pick up voicemail - no response by PBX to DTMF digits
  3. Place external call to reach internal extension (PSTN -> FXO -> PBX -> Extn). Internal extension rings, but no external voice heard.

Have tried converting Chan_PJSIP to Chan_SIP, but then PBX refuses to register the endpoints.

Any thoughts/suggestions most welcome.

Hi @andrewr123
What about your PBX Firewall configuration? You can try to add your Local Network on PBX Firewall TRUSTED Networks ( 192.168.XX.XX/24) and same network range on Asterisk SIP Settings --> General Sip Settings --> Local Networks --> 192.168.XX.XX/24


Maybe all your RTP is being sent to Sangoma:

They’re listening…

As @snazir says. Note that when you change the SIP Settings, you must restart (not just reload) Asterisk.

IMO this is very unlikely to be a pjsip issue, but if you convert an extension to chan_sip, you must either change the config in the device to register to port 5160, or change the port setup at the PBX end (requires restart).

Thanks for the help guys, problem solved!

Per @snazir, I needed to set the Local Network in General SIP settings (there doesn’t seem to be a firewall on Debian 10, so that wasn’t the issue). Never had to worry about this on my previous install!

@billsimon - interesting; the default NAT address in the RPi build is, so not everything goes to Sangoma! Now correctly to my own IP (separate issue)

Maybe a residential IP that got packaged in with the files you used to install your RPi FreePBX setup.

% Information related to ''

descr:          Kabeldeutschland Route
origin:         AS31334
created:        2009-11-02T10:30:50Z
last-modified:  2009-11-02T10:30:50Z
source:         RIPE

% This query was served by the RIPE Database Query Service version 1.97 (ANGUS)

Yup, I guess that’s it - seems to have German origins, so a German IP as default would make sense

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.