Inbound route / wildcard numbers

I had an inbound route setup with the following CallerID Number -

CallerID Number _202NPNNNNN

Because I was getting lots of calls from “charity” organizations in that area code. I set it to go direct to voicemail. I think it worked and matched all numbers from 202. Although, that was google that gave me the instructions so I’m not sure it was the most proper solution.

With a recent update I am getting the following when I try to save changes to that inbound route -

CIDNUM can only be numbers, A-D, * and #. DID may also start with a +

Is what I was doing legal? I have found other references using an X instead of the N/P but that doesn’t work either.


First: You dial pattern was not correct, ‘P’ is not valid, and using ‘N’ doesn’t do what you think it does. Read this.

Second: The prohibition against entering underscore prefixed patterns in this field is a bug, open a ticket at

CIDNUM is the incoming Caller ID of the people calling you. You’ve got that.

DID is the Direct Inbound Dial number that is being called. It needs to match the inbound number being sent by your VOIP provider. That’s why it’s OK for DID to include a “+”.

The Asterisk Wiki at Asterisk Pattern Matching speaks to this, but not in a way that is easily managed in FreePBX.

At this point, I’d suggest putting in a feature request, since I’m not sure how to proceed from here. Wildcards are out of the question, it would appear, but there’s probably something under the hood that one of the regulars might know about.

Ok - my pattern was very wrong. Good thing all the junk calls matched my stupidity, I really would have scratched my head when one made it through due to my excessive use of N.

So my corrected understanding is

_202NPNXXXX (or possibly even _202XXXXXXX)

could be allowed in that field and it would work and do what I initially was attempting to do. But Freepbx is currently sanitizing the input and is a bit over restrictive?

Did you ever submit a ticket like Lorne said, or are you just gonna stand around and whine?

Just like in the DID matching, for years for readability for clients we listed numbers as xxx-xxx-xxxx (ie 410-342-5678) and on most of our installs the listings all display this way. I tried to add in a DID and realized this can no longer be done.

I know it’s not technically legal matching, but it’s always worked, and is very much was what people are used to seeing. I knew FPBX stripped the - for Asterisk, but visually it was nice in the GUI…

Seriously? It’s only been a few hours. I’m just trying to understand and make sure there is not more to my mistake. Yes, I will submit a ticket. I have submitted tickets before… And Lorne and Andrew and Others have done fantastic job resolving them to the benefit of all FreePBX users.

I too am having this problem… I used to have an incoming CID pattern


but just did a fresh install of latest FreePBX 13 and getting same error as brk…

After reading the suggested article above it specified patterns start with underscore so I updated my pattern with


still no luck…
furthermore article said use period for any remaining digits

so i tried


and still got same error message box

“CIDNUM can only be numbers, A-D, * and #. DID may also start with a +”

Could this be a bug on FreePBX 13 I also have the same
Hope we get directions

watch this ticket:

For what it’s worth the changes made by the TheJames here seemed to have done the trick…

It all went well and accepted various patterns like _800531. and _80053[1-2]. and _800531XXXX
I look forward to the Published version so I can update properly. The hand editing resulted in file signature errors.