Inbound Route DID choosing the catchall route


I installed the FreePBX distro from an ISO. I then performed the usual configurations and everything seemed to be going fine. I did run into a weird issue that i would like some advice on. The issue i’m referring to is after i created an inbound route with a DID it didn’t. The call was passed onto the catchall route and on the asterisk console it in fact gave the “you should probably have a did for this” message. After some research i came up with this:

And then changed the DID from 1235551212 to _.1212 This made all of the calls including the catchall hit the route for this DID. I then played a bit with the pattern matching syntax but i didn’t succeed.

According to that other forum post and other bug reports in FreePBX there was an issue with PHP 5.3.3 so i upgraded the system to 1.815.210.58-1 which gives me PHP 5.3.10 which supposedly resolved this issue.

What should i try next as i’m pretty confused?

I have:

  • Updated to a newever version of PHP
  • Verfied that the DID coming in from my SIP provider is handing the correct digits (This was a replacement of an Elastix (Asterisk 1.6) system where it worked with these exact settings)
  • I did not experience the negative number in the dial plan that others mentioned in the PHP bug; AFAIK the dial plan is correct but doesn’t work.

I noticed that there is a 1.10x branch available; should i be using that instead? Please let me know what steps i should take to provide more information.

Thank you in advance,

Simply configure each additional line appearance that you want in rollover on the line key. You can have the same line appear more that once since the phone has a single IP.

SkykingOH - Thanks for the reply but i don’t think your reply was intended for me. Any help would be appreciated.


Odd, not sure how that could have happened. I was just using a reply window.

have any suggestions on what i should try next? This is really baffling me and i cannot imagine that this is not an important feature for others as well.