Inbound faxing with freepbx

Hi,

I’m trying to route fax from one E1 to 8 fax IAX2 extensions on my office, but can’t make it working :frowning:

I have configured Hylafax + iaxmodem and the 8 iax2 extensions. If I call to my freepbx box and select the fax extension from the IVR the fax is sent to the e-mail selected on the hylafax FaxDispatch file.

I want to assign to every fax extension one DID, it means if our customers call to 13051230502 the call will be routed to the fax extension 502, if the call is for 13051230503 the call will be routed to the fax extension 503, etc.

I’m triying this addind the DID number on the “Direct DID” box, but when I call from outside to 13051230502 the IVR is answering the call and not the fax. On my Inbound routes I’ve this:

*  Add Incoming Route
* any DID / any CID
* 13051230502 / any CID
* 13051230503 / any CID

Seems like freebpx is giving the priority to any DID/ and CID to the calls for 13051230502.

Have you any ideas about it?

Thank you very much, greetings from Ecuador - South America :slight_smile:

check how your dids are coming in. In most cases that I have seen, it would come in one of two ways, either “3051230502” or “+13051230502” although there may be other formats as well.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Humm… I think the trouble is with my provider, it is not sending me the callerid… I’ve this at the log:

[Sep 20 10:58:53] VERBOSE[7794] logger.c: – Executing [[email protected]:1] NoO
p(“Zap/4-1”, "Entering from-zaptel with DID == ") in new stack
[Sep 20 10:58:53] VERBOSE[7794] logger.c: – Executing [[email protected]:3] Set
(“Zap/4-1”, “DID=s”) in new stack
[Sep 20 10:58:53] VERBOSE[7794] logger.c: – Executing [[email protected]:4] NoO
p(“Zap/4-1”, “DID is now s”) in new stack
[Sep 20 10:58:53] VERBOSE[7794] logger.c: – Executing [[email protected]:1] Set(“
Zap/4-1”, “__FROM_DID=s”) in new stack

It is a problem of my provider or I need to enable something to get the called number on freepbx?

Thank you again.

Only the good die young

Humm… it’s not a provider error. I’ve one trixbox machine, I’ve connected it an the DID number is received fine. let me check the zapata.conf file for differences.

Regards,

Only the good die young

I've run into at least one provider who sends the DID info based on how you register. e.g. you put the DID at the end of the register string, like this:

 register=508481NNNN:[email protected]/1508481NNNN