Inbound DID problem via SIP PRI gateway

We have a MultVoIP SIP PRI gateway connected directly out telco provider giving us 100 DID numbers. Outbound Dialing seems to work flawlessly but I cannot get any inbound dialing to work whatsoever no matter what I do. I assign a DID number to each extension. Then I have my trunk which is configured like this:

context=from-pstn
type=peer
insecure=very
host=“gateway IP address”

Everytime I try to dial in here’s what I get from the CLI

-- Executing [[email protected]:1] Set("SIP/5060-09457190", "__FROM_DID=3154426111") in new stack
-- Executing [[email protected]:2] GotoIf("SIP/5060-09457190", "1 ?cidok") in new stack
-- Goto (from-pstn,3154426111,4)
-- Executing [[email protected]:4] NoOp("SIP/5060-09457190", "CallerID is "3153806690" <3153806690>") in new stack
-- Executing [[email protected]:5] Goto("SIP/5060-09457190", "from-did-direct|6111|1") in new stack
-- Goto (from-did-direct,6111,1)
-- Executing [[email protected]:1] Macro("SIP/5060-09457190", "exten-vm|6111|6111") in new stack
-- Executing [[email protected]:1] Macro("SIP/5060-09457190", "user-callerid") in new stack
-- Executing [[email protected]:1] NoOp("SIP/5060-09457190", "user-callerid: 3153806690 3153806690") in new stack
-- Executing [[email protected]:2] Set("SIP/5060-09457190", "AMPUSER=3153806690") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/5060-09457190", "0?report") in new stack
-- Executing [[email protected]:4] ExecIf("SIP/5060-09457190", "1|Set|REALCALLERIDNUM=3153806690") in new stack
-- Executing [[email protected]:5] NoOp("SIP/5060-09457190", "REALCALLERIDNUM is 3153806690") in new stack
-- Executing [[email protected]:6] Set("SIP/5060-09457190", "AMPUSER=") in new stack
-- Executing [[email protected]:7] Set("SIP/5060-09457190", "AMPUSERCIDNAME=") in new stack
-- Executing [[email protected]:8] GotoIf("SIP/5060-09457190", "1?report") in new stack
-- Goto (macro-user-callerid,s,13)
-- Executing [[email protected]:13] NoOp("SIP/5060-09457190", "TTL:  ARG1: 6111") in new stack
-- Executing [[email protected]:14] GotoIf("SIP/5060-09457190", "0?continue") in new stack
-- Executing [[email protected]:15] Set("SIP/5060-09457190", "__TTL=64") in new stack
-- Executing [[email protected]:16] GotoIf("SIP/5060-09457190", "1?continue") in new stack
-- Goto (macro-user-callerid,s,23)
-- Executing [[email protected]:23] NoOp("SIP/5060-09457190", "Using CallerID "3153806690" <3153806690>") in new stack
-- Executing [[email protected]:2] Set("SIP/5060-09457190", "FROMCONTEXT=exten-vm") in new stack
-- Executing [[email protected]:3] Set("SIP/5060-09457190", "VMBOX=6111") in new stack
-- Executing [[email protected]:4] Set("SIP/5060-09457190", "EXTTOCALL=6111") in new stack
-- Executing [[email protected]:5] Set("SIP/5060-09457190", "CFUEXT=") in new stack
-- Executing [[email protected]:6] Set("SIP/5060-09457190", "CFBEXT=") in new stack
-- Executing [[email protected]:7] Set("SIP/5060-09457190", "RT=15") in new stack
-- Executing [[email protected]:8] Macro("SIP/5060-09457190", "record-enable|6111|IN") in new stack
-- Executing [[email protected]:1] GotoIf("SIP/5060-09457190", "0?2:4") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing [[email protected]:4] AGI("SIP/5060-09457190", "recordingcheck|20080320-161617|1206044177.68") in new stack

I can really use any help to fix this. I’ve been struggling with it for weeks now
Thanks

You need to post more of the call flow as there is not a error in what you have posted as it has not gotten to the end of the dial plan flow yet.

it seems that the “6111” inbound route or did is being matched, do you have an inbound route with xxxxxx6111 in it?

How many digits is your provider passing to you, and like lazytt asks - do you have an inbound route defined for that DID?

after struggling with this for two months I finally got my breakthrough. It was a configuration mismatch on between my gateway and the provider which i just figured out right after posting this. My trixbox settings turned out to be correct. Funny how things can work out in the oddest times.

Thanks everyone for trying to help.