Inbound DID ported to Nextiva and configured but incoming not working

Hi all,

I am having a strange issue.

I have ported my DIDs to nextiva but what is happening is that I can see the trunk registered and my outbound calls are also working fine.

I have one DID from other carrier and it’s working fine with the same trunk but I hear beeps and one ring with a message all circuits are busy.

I can’t see hit on the server also.

I need a real fix as this server in production with no backup plan.

Trunk Outgoing Settings

type=peer
host=[host]
canreinvite=no
disallow=all
allow=ulaw&alaw
insecure=port,invite
dtmfmode=auto&rfc2833
fromdomain=[domain]
qualify=yes
maxexpirey=3600
defaultexpirey=60
session-timers=refuse
nat=yes
fromuser=[user]
username=[user]
secret=[key]
dtmf=auto
sendrpid=yes
context=from-trunk

Incoming Settings
User Context= [user]
User Details:

auth=md5
secret=[key]
type=user
context=from-internal
disallow=all
allow=ulaw&alaw
sendrpid=yes

Register String: user:[email protected]/user

I don’t know nextiva but most carriers don’t need anything under the incoming settings and will send calls to the sip registration. Just set the type to friend instead of peer.

Did you set the DID to route properly, and do you see anything in the Asterisk logs that might indicate what the problem is?

I have been insisting the Nextiva support Engineer all the time that I am not getting hit from ported numbers and he keeps saying me that number is ported your server rejecting the calls but it comes to an end with the porting issue that porting is not completed yet.

So I will wait once porting completing and I will check if I face any issue again.

Thanks for coming up yois. :slight_smile:

This community is worth sharing.

Everyone is helping.

Guys strange things happening both the parties the previous owner and the new owner they are saying porting is completed.

now rules are set on my end but all of the ported DIDs I am not receiving any calls not a single incoming hit.

trunk is up and on the same trunk with another inbound number I am able to get hits on my server which freepbx 13.

just a strong beep smashing ears or sometimes error message from my calling party.

Any help will be appreciated.

I am also seeing a strange thing.

One of the DID which we bought from Nextiva is working fine but when we call that DID and see the CDRs it shows the username of the nextiva account as a DID instead of that DID number and by reading one of the posts from someone said also create username of the account as DID and that’s why I created that as a DID.

Can anyone help me on this

Guys worked.

Issue at Nextiva end and seriously their support sucks…

Issue resolved by nextiva…

Thanks all for coming up.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.