FreePBX | Register | Issues | Wiki | Portal | Support

Inbound CID is showing CID:<extension outound CID> in call history


#1

This only started happening after reconfiguring an old PBX in FreePBX (the old one was PBX-in-a-flash). It’s not a complicated setup: one main location where the PBX is and another location where the phones are connected to the PBX through a VPN. This setup has not changed, the phones have not changed. The only thing that has changed is I copied all the trunks, routes, extensions, etc. from the old PBX and put them in a new one.

Now, when I call them, they see the appropriate CID during the call. But after the call, the call history shows THEIR EXTENSION’S outbound CID.

This is very puzzling and I’m sure I’m missing something simple. Please help me if you can.

Thanks!


(Dave Burgess) #2

Call history “at the phone” is usually a function of the interaction of the phone and the SIP Headers. You never mentioned the type of phone or if you’ve made any changes that would effect the SIP headers.


#3

Sorry for the delayed response - I’ve tried to research what things I could have done in the FreePBX web interface that would have affected the SIP headers and I just can’t tell or don’t know enough to answer that question. All I know is that I didn’t set this up different from how I’ve ever set up a phone system and this problem is brand new to me. Is there a way I can view the SIP headers on a call or are they written to the logs? We’re using Yealink phones as we do on all our builds.

Thank you for any insight you can give me.


(Dave Burgess) #4

You can’t just use the GUI for problems at this level. You’re going to need to log into the console as ‘root’ and use “asterisk -vvvvvr”

From there, you can do “SIP BEBUG ON” (IIRC). This will display the SIP information on the screen (and in the /var/log/asterisk/full log file) so you can review the options that are being used.

Also, are you looking at the CEL database, or the CDR database?


(Christoph Scheidl) #5

Hello, I know this is now a long time due, but I just found out how to fix that:

In FreePBX, go to Settings -> Advanced Settings -> “Display CallerID on Calling Phone” and deactivate that.
That’s all it needs!