Inbound calls - Status: 401 Unauthorized

I’ve been on a call with our SIP Trunk provider, and so far we can do Outbound calls, but Inbound calls aren’t working yet.

I run a packet capture (tshark) from the command line & when I call in from an outside number, I see our server giving the SIP provider a “Status: 401 Unauthorized” message.

I have tried removing the “secret” from the extension (pjsip) I have the call routed to. I’ve tried routing to an IVR instead of an extension. Also tried disabling the firewall, still no change.

Is this something I can get help with here, or is this more of an Asterisk community question? I wasn’t sure if this could be some settings that are accessible through FreePBX or not.


Is that a chansip trunk connection to your provider?

Traditionally the way to prevent asterisk from challenging the provider with a 401 unauthorized for authentication was to have insecure=invite in your trunk peer details.

Newer versions of Asterisk have parameter “remotesecret” that deals with this issue as well. But you would have to read on that.

If you use pjsip you have to check the documentation for this setting.

Thank you for your quick reply. After 2 days of searching and trying things, today (just after posting of course) I figured out why Inbound calls weren’t coming through.

My provider presents the number to us as “+1XXXXXXXXXX” and my Inbound route was looking for the number without the “+1” :slight_smile:

Level3 (now CenturyLink) uses a peering setup where there is no registration. It’s IP-based, so that’s what was throwing me off. It looks like the “401 Unauthorized” message just wasn’t clear enough.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.