Inbound calls not working

I’ve got a new FreePBX 13 system installed and configured with Twilio SIP trunks. I am able to make outbound calls without any problems. However I am not make any inbound calls to the FreePBX system. I’ve tripled check the inbound routes and the trunk settings on FreePBX and still unable to make any inbound calls. I also followed Twilio configuration guide and cant seem to find an issue with the settings. I also made sure certain UDP ports were forwarded in the firewall. I get no ringing or dial tone when dialing the freepbx from an outside phone. Not sure if its a freepbx issue, a trunk issue, or firewall issue. Any help is greatly appreciated.

Logs, it always takes logs. !!

Do you have an “any/any” inbound route?

Hi
Like Dicko said. Need logs or other information.
for example: sip set debug on
and next, make call.
sip set debug off, to stop any traces.

You should see something about your SIP Provider (ip address) in the tag : From
Also. you can use tcpdump with some specific arguments and read the result with Wireshark or with other tools.

The main issue about that, is ANY/ANY indeed.
You should accept all incoming calls before to setting up any DID at first. Just to be sure that you receive a call.
Sometime, the DID is not matched, maybe caused by a wrong pattern into this field.

Just an idea like that.

Thanks. I’ll run sip set debug and review the logs.

I dont believe so. How do you set one up?

Check the standard Trunk issues. Make sure the Trunk names are the same on both sides.
Double check the passwords.

Twillo would probably be the next step. if the call is not hitting the pbx.

Check Under REPORTS> Asterix Info > Peers and make sure yo see the phones
Under REPORTS > CDR reports check for the call.

Call twillo, see if they see the call, or find the call reports in their system and see what is happening with the call.

Set up an inbound route but do not specify a DID or an inbound CID - just leave them blank.

Not sure what I’m looking at but I see entries in blue font that are repeated in the logs.

[2017-10-07 11:41:01] NOTICE[2169] chan_sip.c: Received SIP subscribe for peer without mailbox: 202
[2017-10-07 11:41:03] NOTICE[32090] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘sip:[email protected];pstn-params=9084818088;cpc=ordinary’ failed for ‘54.172.60.1:5060’ (callid: [email protected]) - No matching endpoint found
[2017-10-07 11:41:03] NOTICE[32090] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘sip:[email protected];pstn-params=9084818088;cpc=ordinary’ failed for ‘54.172.60.0:5060’ (callid: [email protected]) - No matching endpoint found
[2017-10-07 11:41:03] NOTICE[32090] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘sip:[email protected];pstn-params=9084818088;cpc=ordinary’ failed for ‘54.172.60.0:5060’ (callid: [email protected]0.0) - No matching endpoint found

Also what should be the minimum Incoming sip settings on the trunk. Based on Twilio’s website, they only show the following:

secret=password
host=1.2.3.4
type=peer
context=from-trunk

I feel like we need more settings here because I noticed other examples of SIP settings I come across have more parameters. Do I need to add any more parameters?

It appears you have a chan_sip trunk, but inbound calls are being received by the pjsip driver. Are you using the correct port?

[2017-10-07 11:41:03] NOTICE[32090] res_pjsip/pjsip_distributor.c: Request 'INVITE' from '' failed for '54.172.60.1:5060' (callid: [email protected]) - No matching endpoint found

Where can I verify the port #?

I found where the mistake was. I had the ports backwards between Chan_sip and PJSIP. Inbound calls are now working. Thanks all.