Inbound Caller Name not displayed on phone

Hi, I get the Remote-Party-ID in the invite, but the phone displays the Caller Number twice. I’ve read a few other threads on this and I’ve tried changing settings trustpid and senrpid on the extension and in advanced settings, but can’t make it work. Thanks for any advice.

FreePBX Asterisk (Ver. 11.14.2)

If using chan_sip add trustrpid=yes to the trunk peer details. If using PJSIP, locate the toggle to enable it.

Thanks so much for the reply. I did that.

I since learned that it works on some phones…

Two identical Polycom phones, same software on phones. Both have a DID with an Inbound Route. One shows number and name, the other shows number and number. All settings on the inbound routes and extensions are the same… I stumped.

Depending on which Polycom phone model you’re using, the phone itself may be conspiring against you.

On our SoundPoint IP550 and IP335 endpoints, browse to the phone’s IP address & log in as Admin. Go to Utilities->Line Key Configuration & see if there are any numbers in the list. If there are, whatever is there will override whatever FreePBX sends the phone.

IMNERHO, that’s just about the most bone-headed idea I’ve ever encountered, especially if you have more than 3-4 endpoints – you have to touch each one by the same, awkward, laborious process & hand-enter/edit what you want to appear on the display.

If the rest of the program worked – especially if it wasn’t such a PITA to navigate & configure the things, I might not mind so much, but it has made me really strongly dislike PolyCom (their BS “support” doesn’t help – I got this from a remote-support event from a Sangoma master).


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.