Inbound call to main line - IVR problem

Am running AsteriskNow with upgraded asterisk to version 1.6.0 and FreePbx ver. 2.7

Upon dialing the main number from an inbound extension I can not hear the IVR Messages, It will start ringing once the ring group picks it up.

As you can see below from my verbosity that it is playing the message, Just can’t hear it.

This works fine for Incoming calls from an outside line.

Anyone have any insight for this?

Thanks in advance,
Joe

here is my verbosity output:

Connected to Asterisk 1.6.0.25 currently running on asterisk002 (pid = 11737)
Verbosity is at least 24
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] Macro(“SIP/6010-000000a7”, “user-callerid,SKIPTTL,”) in new stack
– Executing [[email protected]:1] Set(“SIP/6010-000000a7”, “AMPUSER=6010”) in new stack

------------- cut out to slim down -----if need more info please ask ----------------

-- Executing [[email protected]:18] GotoIf("SIP/6010-000000a7", "0?customtrunk") in new stack
-- Executing [[email protected]:19] Dial("SIP/6010-000000a7", "SIP/vonage-185665xxxxx/185665xxxxx,300,") in new stack

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called vonage-185665xxxxx/185665xxxxx
– Now forwarding SIP/6010-000000a7 to ‘Local/[email protected]’ (thanks to SIP/vonage-185665xxxxx-000000a8)
– Executing [[email protected]:1] Set(“Local/[email protected];2”, “GROUP()=OUT_8”) in new stack
– Executing [[email protected]:2] Goto(“Local/[email protected];2”, “from-trunk,185665xxxxx,1”) in new stack
– Goto (from-trunk,185665xxxxx,1)
– Executing [[email protected]:1] Set(“Local/[email protected];2”, “__FROM_DID=185665xxxxx”) in new stack
– Executing [[email protected]:2] ExecIf(“Local/[email protected];2”, “0 ?Set(CALLERID(name)=)”) in new stack
– Executing [[email protected]:3] Set(“Local/[email protected];2”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:4] Set(“Local/[email protected];2”, “CALLERPRES()=allowed_not_screened”) in new stack
– Executing [[email protected]:5] Goto(“Local/[email protected];2”, “ivr-8,s,1”) in new stack
– Goto (ivr-8,s,1)
– Executing [[email protected]:1] Set(“Local/[email protected];2”, “MSG=custom/en-ffa-greeting”) in new stack
– Executing [[email protected]:2] Set(“Local/[email protected];2”, “LOOPCOUNT=0”) in new stack
– Executing [[email protected]:3] Set(“Local/[email protected];2”, “__DIR-CONTEXT=default”) in new stack
– Executing [[email protected]:4] Set(“Local/[email protected];2”, “_IVR_CONTEXT_ivr-8=”) in new stack
– Executing [[email protected]:5] Set(“Local/[email protected];2”, “_IVR_CONTEXT=ivr-8”) in new stack
– Executing [[email protected]:6] GotoIf(“Local/[email protected];2”, “0?begin”) in new stack
– Executing [[email protected]:7] Answer(“Local/[email protected];2”, “”) in new stack
– Executing [[email protected]:8] Wait(“Local/[email protected];2”, “1”) in new stack
– Executing [[email protected]:9] Set(“Local/[email protected];2”, “TIMEOUT(digit)=3”) in new stack
– Digit timeout set to 3
– Executing [[email protected]:10] Set(“Local/[email protected];2”, “TIMEOUT(response)=0”) in new stack
– Response timeout set to 0
– Executing [[email protected]:11] Set(“Local/[email protected];2”, “__IVR_RETVM=”) in new stack
– Executing [[email protected]:12] ExecIf(“Local/[email protected];2”, “1?Background(custom/en-ffa-greeting)”) in new stack
– <Local/[email protected];2> Playing ‘custom/en-ffa-greeting.ulaw’ (language ‘en’)

------------- cut out to slim down -----if need more info please ask ----------------

-- Executing [[email protected]:3] AGI("Local/[email protected];2", "dialparties.agi") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi

dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘FFA:Free For All Incorporated’ number is ‘unknown’
> dialparties.agi: USE_CONFIRMATION: ‘FALSE’
> dialparties.agi: RINGGROUP_INDEX: ''
dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 3010 to extension map
– dialparties.agi: Added extension 3020 to extension map
– dialparties.agi: Added extension 6000 to extension map
– dialparties.agi: Added extension 3030 to extension map
– dialparties.agi: Extension 3010 cf is disabled
– dialparties.agi: Extension 3020 cf is disabled
– dialparties.agi: Extension 6000 cf is disabled
– dialparties.agi: Extension 3030 cf is disabled
– dialparties.agi: Extension 3010 do not disturb is disabled
– dialparties.agi: Extension 3020 do not disturb is disabled
– dialparties.agi: Extension 6000 do not disturb is disabled
– dialparties.agi: Extension 3030 do not disturb is disabled
> dialparties.agi: extnum 3010 has: cw: 1; hascfb: 0 [] hascfu: 0 []
– dialparties.agi: DbDel CALLTRACE/3010 - Caller ID is not defined
> dialparties.agi: extnum 3020 has: cw: 1; hascfb: 0 [] hascfu: 0 []
– dialparties.agi: DbDel CALLTRACE/3020 - Caller ID is not defined
> dialparties.agi: extnum 6000 has: cw: 1; hascfb: 0 [] hascfu: 0 []
– dialparties.agi: DbDel CALLTRACE/6000 - Caller ID is not defined
> dialparties.agi: extnum 3030 has: cw: 1; hascfb: 0 [] hascfu: 0 []
– dialparties.agi: DbDel CALLTRACE/3030 - Caller ID is not defined
– dialparties.agi: Filtered ARG3: 3010-3020-6000-3030
> dialparties.agi: NODEST: 96410 adding M(auto-blkvm) to dialopts: trM(auto-blkvm)
> dialparties.agi: NODEST: 96410 blkvm enabled macro already in dialopts: trM(auto-blkvm)
– <Local/[email protected];2>AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“Local/[email protected];2”, “SIP/3010&SIP/3020&SIP/6000&SIP/3030,20,trM(auto-blkvm)”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called 3010
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called 3020
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called 6000
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called 3030
– SIP/3020-000000aa is ringing
– SIP/3010-000000a9 is ringing
– SIP/3030-000000ac is ringing
– SIP/6000-000000ab is ringing

Codecs don’t match? How have you recorded your IVR? Did you do it through the System Recordings? It will automatically record in the correct format 64 kbps 8000 hz sampling. If you use WinXP recorder then it most likely will not record in the proper sampling format.

t5hat may be it, has the sample rate changed from asterisknow 1.0 to asterisknow 1.5? Or from asterisk 1.4 to asterisk 1.6 ?

These recording were taking off the old phone system, and have been created by asterisk 1.4.

They are in ulaw format don’t know of the sample rate for it has been some time since we have created those recordings.

But anyways We can hear the recordings fine calling from an outbound number (my cell) but when I call from an inbound extension (sip-extension phone) we can not hear those recordings.

If this was a codec issue why would we hear the recording calling from an outbound number.

Also extension is set to allow ulaw.

Well on the conference line, if I bring the custom greeting message to the conference line and dial… I can hear it fine. Its just when dialing the main number I don’t know what it could be.