Inbound call fails


(Ken Yiu) #1

Re:FreePBX 15.0
I’m troubleshooting the inbound call failure. The outbound is working just fine. I’m not getting any inbound calls. When I called the numbers I this error message on asterisk:
I got this error message on asterisk: WARNING[31542][C-0000000d]: Ext. s:7 @ from-sip-external: “Rejecting unknown SIP connection from 169.55.63.65:5060”. Looks like my ISP routed the call to my server, for unknown reason it get dropped instead of routing it to an extension. Why?


(Andrew) #2

If you receive this error message but the call is expected from your provider, your incoming settings on your trunk is not setup correctly for how the provider is sending you the calls.


(David55) #3

A common cause of this sort of failure, on FreePBX, is enabling both chan_sip and chan_pjsip, but configuring for incoming calls in chan_sip, Generally you want to disable chan_sip and only use chan_pjsip.


#4

This error occurs when the incoming call cannot be matched to a trunk. If this is a pjsip trunk, set Match (Permit) to the list of all addresses from which the provider can send calls.

If chan_sip and using IP auth, if Bind Port is 5160 you’ll need to specify that port on the provider’s portal. A few providers including Vitelity don’t support that, though you can use Vitelity with registration on a non-standard port.

For other situations, please provide details.


(Ken Yiu) #5

here’s the setup:
OUTGOING:
type=friend
trustrpid=yes
sendrpid=no
qualify=yes
keepalive=45
insecure=port,invite
host=xxx.xxx.com
fromdomain=server.isp.com
dtmfmode=rfc2833
disallow=all
directmedia=no
context=from-trunk
allow=ulaw, alaw

INCOMING:
type=friend
port=5060
host=server.isp.com
context=from-trunk


(Ken Yiu) #6

FYI, my isp said they don’t support pjsip…


(Andrew) #7

That’s ridiculous. PJSIP is just a channel driver - it’s still SIP.


#8

As ever, we will ask you to pastebin a log of a failed call.


(Ken Yiu) #9

Yes, I’ve setup pjsip previously and got no where. I switched to chan_sip to try for a better luck. At least chan_sip is giving the error message. I got nothing with pjsip.


#10

Without a log everyone , including you, will continue to guess . . .


(Ken Yiu) #11

Sorry…where is the log file:kissing_closed_eyes:


#12

Try this for a simple fix; you can clean it up later:

Create a new pjsip trunk (leave the chan_sip trunk in place for outgoing).
Registration: None
Authentication: None
SIP Server: sbc1.ixica.com
Match (Permit): 169.55.63.65,199.247.85.15,184.169.220.75,64.120.214.84

If needed, set up a catch-all Inbound Route to see the format they are using for the DID.


#13

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


#14

log file is in
/var/log/asterisk/full
To see the SIP details, at the Asterisk command prompt (not a shell prompt) type
pjsip set logger on
sip set debug on
make the failing incoming call, then paste the Asterisk log for the call.


(Ken Yiu) #15

wow!! that works. I’ve disable the chan_sip trunk - just running on the pjsip. Both inbound and outbound is working. Seems my isp tech doesn’t know about their own system. pjsip works on their trunks.


(Ken Yiu) #16

BTW, I made the mistake on disclosing my sip trunk server ip. Can you guys mask it out for me? thanks,


#17

No, but you can edit your post


(Ken Yiu) #18

I’ve done that already


(Ken Yiu) #19

I’m curious, how did you find out the list of ip address for the server?


(Jared Busch) #20

You realize, that it is impossible for these to be secret right?