IMPORTANT: Critical packaging error has broken sysadmin (and firewall!)

I’ll be opening a ticket shortly, but I just discovered that one of my hosted machines was hacked, and firewall wasn’t working.

Sangoma have accidentally released a new package of sysadmin (sysadmin.noarch 0:5.6-5.6.50.sng) which is encoded with ioncube for php 7.2 (instead of zend for 5.6).

You’ll need to yum downgrade sysadmin and roll back to sysadmin-5.6-5.6.47.sng.noarch

This now appears to be fixed in sysadmin-5.6-5.6.52.sng, and I didn’t even need to open a ticket!

However, any machine that downloaded .50 while it was available is now 100% broken and can’t auto heal. If you’re unsure if your machine is broken, a simple test is:

[[email protected] ~]# /usr/bin/sysadmin_manager firewall.firewall
PHP Fatal error:
The file /usr/lib/sysadmin/includes.php was encoded with the Encoder for PHP 7.2 and can only run on PHP 7.2 or later.
If you are the administrator of this site then please upgrade to PHP 7.2 or later and install the corresponding ionCube Loader. in Unknown on line 0
[[email protected] ~]#

You can either yum downgrade sysadmin or yum upgrade sysadmin to get .52

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.