Import Contacts with Bulk Handler not working

When i try to import contacts with the Bulk Handler, there is no “import” or “proceed” button. I also get errors in the browser console:

JQMIGRATE: Logging is active
config.php?display=bulkhandler&activity=validate:4237 Uncaught SyntaxError: Unexpected token <
modernizr.js?load_version= ‘webkitAudioContext’ is deprecated. Please use ‘AudioContext’ instead.(anonymous function) @ modernizr.js?load_version=
pbxlib.js?load_version= Uncaught TypeError: Cannot read property ‘reload_needed’ of undefined(…)

I have posted on and was told to post here.

Thanks for your help,

I just tested using bulk handler ver. with no issue. Is it possible you have the csv file formatted incorrectly?


I am uploading 315 contacts. All 315 contacts show up correctly on the “Data Validation” page, but there is a large white space below the final contact where, according to screenshots i have seen, the “import” or “proceed” button should show. Please see attached

I have tried Bulk Handler, with FreePBX running on x86 and ARM (Raspberry Pi), using Chrome, Firefox and IE. All show errors with config.php and pbxlib.js in the browser console.

EDIT: FIXED. Fields such as fname, lname, title, and so are on required. They can be left empty, but the fields must still be present.

EDIT2: The Required/Recommended Headers sample is wrong. it states phone_1_number is before phone_1_type. This is wrong, it’s phone_1_type,phone_1_number

EDIT3: The grouptype must be lower case, i.e. external NOT External


I tried again with a one-line .csv file, and the import button showed up this time, so the problem must have been an incorrectly formatted csv file as you said!

However, when I submit my new file, I get:

Undefined index: fname

Any idea what this could be?

Feel free to summarize your findings in a ticket:

The ordering of headers does not matter