IAXModem Setup Frustration (SOLVED)

I have a FreePbx 2.6 RC2.1 installation (based on the ASteriskNow Project) and I’m trying to get the IAXModem\Hylafax installation up and running.
I’ve been able to successfully install the latest versions of IAXModem and Hylafax and it appears that all services are running successfully. I have a DID pointed to the Fax Modem extension configured in the gui, but whenever I attempt to call into that number and get a fax tone, it’s going to busy and I’m seeing error messages in the asterisk console. I’ve been through at least 4 websites on how to do this configuration and I’m completely at a loss:

Hardware:
PRI line with TE122P Digium Card

ASterisk Console Output error:
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“DAHDI/19-1”, “IAX2/101||tr”) in new stack
– Called 101
– Hungup ‘IAX2/101-1037’
== Everyone is busy/congested at this time (1:0/0/1)

Output of Iaxmodem, Hylafax and IAX2 Peers:
[[email protected] ~]# ps -ef | grep iax
uucp 3182 1 0 19:10 pts/3 00:00:00 iaxmodem ttyIAX1
uucp 3189 1 0 19:10 pts/0 00:00:00 iaxmodem ttyIAX2
uucp 3192 1 0 19:10 pts/2 00:00:00 iaxmodem ttyIAX3
uucp 3201 1 0 19:10 pts/1 00:00:00 iaxmodem ttyIAX4
root 3718 3249 0 19:17 pts/4 00:00:00 grep iax

[[email protected] ~]# ps -ef | grep fax
uucp 2788 1 0 19:09 ? 00:00:00 /usr/local/sbin/faxq
uucp 2790 1 0 19:09 ? 00:00:00 /usr/local/sbin/hfaxd -i hylafax
uucp 3185 1 0 19:10 ? 00:00:00 /usr/local/sbin/faxgetty ttyIAX1
uucp 3190 1 0 19:10 ? 00:00:00 /usr/local/sbin/faxgetty ttyIAX2
uucp 3194 1 0 19:10 ? 00:00:00 /usr/local/sbin/faxgetty ttyIAX3
uucp 3203 1 0 19:10 ? 00:00:00 /usr/local/sbin/faxgetty ttyIAX4
root 3747 3249 0 19:17 pts/4 00:00:00 grep fax

[[email protected] ~]# faxstat -s
HylaFAX scheduler on ast02: Running
Modem ttyIAX1 (Local DID HERE): Running and idle **I have configured
Modem ttyIAX2 (Local DID HERE): Running and idle **the correct DID’s.
Modem ttyIAX3 (Local DID HERE): Running and idle **Just didn’t want to
Modem ttyIAX4 (Local DID HERE): Running and idle **display them.

ast02*CLI> iax2 show peers
Name/Username Host Mask Port Status
5556 192.168.20.116 (D) 255.255.255.255 4569 OK (2 ms)
104 127.0.0.1 (D) 255.255.255.255 4574 OK (1 ms)
103 127.0.0.1 (D) 255.255.255.255 4573 OK (3 ms)
102 127.0.0.1 (D) 255.255.255.255 4572 OK (3 ms)
101 127.0.0.1 (D) 255.255.255.255 4571 OK (3 ms)
5 iax2 peers [5 online, 0 offline, 0 unmonitored]
== Manager ‘admin’ logged off from 127.0.0.1

I didn’t have the codec of ULAW set on the IAX2 extension that the iaxmodem was using. I had to manually set it under Device Options | Allow. I also added an “all” entry to the Device Options | Disallow. Once I did this, the modems were picking up correctly and processing the faxes as expected.