IAX2 Softphone (Zoiper) won't register after YUM UPDATE (SOLVED)

I recently ran a YUM update for all modules on my AsteriskNOW 1.5 installation. I also upgraded to the lastest version of FreePBX Framework (2.6.0.RC2.1) and the lastest upgrades that go with the base installation. I’ve installed no additional modules. After all this, I was unable to establish a connection using Zoiper via IAX2 to my FreePBX server. I had tested each phase before the yum update and was successful each time in registering the zoiper IAX connection. I’m somewhat of a newb at this and was wondering if anyone knew what I broke just by doing the yum update?
When I turn on IAX debug at Asterisk CLI, all I get is this:

Rx-Frame Retry[ No] – OSeqno: 000 ISeqno: 000 Type: IAX Subclass: REGREQ
Timestamp: 00003ms SCall: 00380 DCall: 00000 []

Rx-Frame Retry[ No] – OSeqno: 001 ISeqno: 001 Type: IAX Subclass: ACK
Timestamp: 00003ms SCall: 00380 DCall: 00001 []

Did you load the Module called IAX Settings? If so, you may want to go to that module and check codecs to make sure they are turned on and hit submit.

I have loaded the IAX Settings module and still no luck. Here are my settings:
codcs: ulaw,alaw,gsm,g729
priority: host
bandwidth: low
video support: disabled
registration: 60-3600
jitter: disabled
lang: blank
bind address: blank
bind port: blank
delay Auth rejects: enabled
other iax: blank

In Asterisk IAX Settings, add to Other IAX Settings the following requirecalltoken=auto and see if that helps.

If you’ve upgraded to the latest version of Asterisk with the IAX denial of service patch then you should be able to add -

calltokenoptional =
maxcallnumbers = 16382

to /etc/asterisk/iax_general_custom.conf to make Asterisk behave the same as before the patch.

More info here - http://sysadminman.net/blog/2009/asterisk-upgrade-breaks-ax-extensions-942

Thanks! That fixed it. Have to read up on this now and figure out how I want to implement this.

Went in and added calltokenoptional and maxcallnumbers as Other IAX Settings in the web gui and that worked. It kept yelling at me that configurations in the iax_general_Custom.conf file were overwriting the values and that they needed to be removed.

Where can I find this module for installation?

I am running AsteriskNow 1.5 and FreePBX v2.5.2

Load the Asterisk IAX Settings Module in the System Administration section. Then you can add the two settings that I have listed above.

I needed to do the full upgrade to 2.6 in order to see this option.


If you go into your terminal window, vmware and log in as root to a command prompt… and do the following

cd /var
cd /log
cd /asterisk
ls -la

you will see your asterisk log files.
Make a test call into your server from an outside line. If the call reaches your server, it will be in the log.

Do a tail 200 to see the last 200 entries…

tail -200 full

for me, I saw this…

[Nov 25 05:42:24] VERBOSE[2876] logger.c: VERSION : 2
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLED NUMBER : xxxxx
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CODEC_PREFS : (alaw|gsm)
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLING NUMBER : xxxxx
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLING PRESNTN : 0
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLING TYPEOFN : 0
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLING TRANSIT : 0
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CALLING NAME : SysFix Group IT S upport
[Nov 25 05:42:24] VERBOSE[2876] logger.c: LANGUAGE : en
[Nov 25 05:42:24] VERBOSE[2876] logger.c: USERNAME : xxxxx
[Nov 25 05:42:24] VERBOSE[2876] logger.c: FORMAT : 8
[Nov 25 05:42:24] VERBOSE[2876] logger.c: CAPABILITY : 65403
[Nov 25 05:42:24] VERBOSE[2876] logger.c: ADSICPE : 0
[Nov 25 05:42:24] VERBOSE[2876] logger.c: DATE TIME : 2010-01-21 20:02 :04
[Nov 25 05:42:24] VERBOSE[2876] logger.c:
[Nov 25 05:42:24] ERROR[2876] chan_iax2.c: Call rejected, CallToken Support requ ired. If unexpected, resolve by placing address xxxxxxxxxxx in the calltokenop tional list or setting user xxxxxxxxxxxxxx requirecalltoken=no
[Nov 25 05:42:24] VERBOSE[2877] logger.c: Rx-Frame Retry[ No] – OSeqno: 001 ISe qno: 001 Type: IAX Subclass: ACK
[Nov 25 05:42:24] VERBOSE[2877] logger.c: Timestamp: 00012ms SCall: 00044 D Call: 00001 [xxxxxxxxxxx:4569]

note: xxxxxxxxx were in fact correct details for my connection but commented out for the purposes of this post.

If you look in the log, you will see that it actually tells you what to do. Okay - i’ve no idea why it says that, or what it means, BUT following it’s own advice solved the problem. I placen the requirecalltoken=no in my trunk directly.

Note: I use Freepbx via ASTERISKNOW

SysFix IT Support London. IT Support for home and business.