IAX2 Extensions not connecting after upgrade to 10.13.66?

Upgraded from 6.12.65 to 10.13.66-6 and my IAX2 extensions are now failing to connect. Suggestions?

12/10 - Still no luck registering IAX extensions.

From the asterisk cli:-

iax2 set debug on

Thanks. I seems that my prior setting for the IAX port (4444) is still in force even though the IAX Settings selection is blank. I have tried setting it to 4569 and I will do it again to see if it takes effect.

Ok, setting to 4569 and restarting Asterisk worked.

Two take aways:

  1. The IAX2 port setting did not display in the IAX2 Settings screen after upgrading and the port setting was, alternatively, not reset to match the blank (default) setting of the screen either. Something wrong there.

  2. If an Asterisk restart is needed following a port change, it would be helpful to mention that in the bubble help or on the screen.

Thanks for your help.

You might file a bug report on this. Usually they pick up on such issues here and correct them pretty quickly but best to file a report. I had a similar issue but with my IP address after upgrading to 10.13.XX



By the way, when reading my entry above I thought that I made a mistake as the two items both begin with the number 1. When I went to correct it using edit, I discovered that the second item is actually labeled correctly ( 2 ) on the edit screen. Very strange.

Use the editor button to insert a numbered list. The digit is the indent level, not the label (if that makes sense).