IAX Trunk "All Circuits Are Busy"


(River Tek) #1

Hello all,

We are asking for little help regarding our trunk setup. First some background, we recently implemented FreePBX server on version 15.0.16.78 using a backup and restore method from the old server. All seems well minus our internal trunk dialing. When dialing an extension on a different phone server we get the “All Circuits Are Busy” message. We’ve quadruple checked the Tunk setup as well as the Outbound setup and cross referenced other working servers and even scoured the oracle google. Below is capture of me dialing through the trunk from extension 2051 to 7048- Any thoughts or suggestions would be greatly appreciated.

Goto (macro-outbound-callerid,s,20)
– Executing [s@macro-outbound-callerid:20] Set(“SIP/2051-00000700”, “USEROUTCID=“2051”<#########>”) in new stack
– Executing [s@macro-outbound-callerid:21] Set(“SIP/2051-00000700”, “EMERGENCYCID=”) in new stack
– Executing [s@macro-outbound-callerid:22] ExecIf(“SIP/2051-00000700”, “0?Set(EMERGENCYCID=)”) in new stack
– Executing [s@macro-outbound-callerid:23] Set(“SIP/2051-00000700”, “TRUNKOUTCID=”) in new stack
– Executing [s@macro-outbound-callerid:24] GotoIf(“SIP/2051-00000700”, “1?trunkcid”) in new stack
– Goto (macro-outbound-callerid,s,30)
– Executing [s@macro-outbound-callerid:30] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERID(all)=)”) in new stack
– Executing [s@macro-outbound-callerid:31] ExecIf(“SIP/2051-00000700”, “1?Set(CALLERID(all)=“Me”<##########>)”) in new stack
– Executing [s@macro-outbound-callerid:32] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERID(all)=)”) in new stack
– Executing [s@macro-outbound-callerid:33] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERID(all)=2051)”) in new stack
– Executing [s@macro-outbound-callerid:34] Set(“SIP/2051-00000700”, “TIOHIDE=no”) in new stack
– Executing [s@macro-outbound-callerid:35] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERPRES(name-pres)=prohib_passed_screen)”) in new stack
– Executing [s@macro-outbound-callerid:36] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERPRES(num-pres)=prohib_passed_screen)”) in new stack
– Executing [s@macro-outbound-callerid:37] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERPRES(name-pres)=prohib_passed_screen)”) in new stack
– Executing [s@macro-outbound-callerid:38] ExecIf(“SIP/2051-00000700”, “0?Set(CALLERPRES(num-pres)=prohib_passed_screen)”) in new stack
– Executing [s@macro-outbound-callerid:39] Set(“SIP/2051-00000700”, “CDR(outbound_cnum)=##########”) in new stack
– Executing [s@macro-outbound-callerid:40] Set(“SIP/2051-00000700”, “CDR(outbound_cnam)=ME”) in new stack
– Executing [s@macro-dialout-trunk:14] GosubIf(“SIP/2051-00000700”, “0?sub-flp-3,s,1()”) in new stack
– Executing [s@macro-dialout-trunk:15] Set(“SIP/2051-00000700”, “OUTNUM=7048”) in new stack
– Executing [s@macro-dialout-trunk:16] Set(“SIP/2051-00000700”, “custom=IAX2/YREKA”) in new stack
– Executing [s@macro-dialout-trunk:17] ExecIf(“SIP/2051-00000700”, “0?Set(DIAL_TRUNK_OPTIONS=M(setmusic^default)T)”) in new stack
– Executing [s@macro-dialout-trunk:18] ExecIf(“SIP/2051-00000700”, “0?Set(DIAL_TRUNK_OPTIONS=TM(confirm))”) in new stack
– Executing [s@macro-dialout-trunk:19] Macro(“SIP/2051-00000700”, “dialout-trunk-predial-hook,”) in new stack
– Executing [s@macro-dialout-trunk-predial-hook:1] MacroExit(“SIP/2051-00000700”, “”) in new stack
– Executing [s@macro-dialout-trunk:20] GotoIf(“SIP/2051-00000700”, “0?skipcrm”) in new stack
– Executing [s@macro-dialout-trunk:21] Set(“SIP/2051-00000700”, “__CRM_DIRECTION=OUTBOUND”) in new stack
– Executing [s@macro-dialout-trunk:22] Set(“SIP/2051-00000700”, “__CRM_DESTINATION=7048”) in new stack
– Executing [s@macro-dialout-trunk:23] Set(“SIP/2051-00000700”, “__CRM_SOURCE=2051”) in new stack
– Executing [s@macro-dialout-trunk:24] AGI(“SIP/2051-00000700”, “sangomacrm.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/sangomacrm.agi
– <SIP/2051-00000700>AGI Script sangomacrm.agi completed, returning 0
– Executing [s@macro-dialout-trunk:25] Set(“SIP/2051-00000700”, “CHANNEL(hangup_handler_push)=crm-hangup,s,1”) in new stack
– Executing [s@macro-dialout-trunk:26] NoOp(“SIP/2051-00000700”, “CRM Finished”) in new stack
– Executing [s@macro-dialout-trunk:27] GotoIf(“SIP/2051-00000700”, “0?bypass,1”) in new stack
– Executing [s@macro-dialout-trunk:28] ExecIf(“SIP/2051-00000700”, “1?Set(CONNECTEDLINE(num,i)=7048)”) in new stack
– Executing [s@macro-dialout-trunk:29] ExecIf(“SIP/2051-00000700”, “1?Set(CONNECTEDLINE(name,i)=CID:##########)”) in new stack
– Executing [s@macro-dialout-trunk:30] ExecIf(“SIP/2051-00000700”, “0?Set(CONNECTEDLINE(name,i)=CID:(Hidden)##########)”) in new stack
– Executing [s@macro-dialout-trunk:31] GotoIf(“SIP/2051-00000700”, “0?customtrunk”) in new stack
– Executing [s@macro-dialout-trunk:32] ExecIf(“SIP/2051-00000700”, “0?Set(DIAL_TRUNK_OPTIONS=)”) in new stack
– Executing [s@macro-dialout-trunk:33] Set(“SIP/2051-00000700”, “HASH(__SIPHEADERS,Alert-Info)=unset”) in new stack
– Executing [s@macro-dialout-trunk:34] Dial(“SIP/2051-00000700”, “IAX2/YREKA/7048,300,Tb(func-apply-sipheaders^s^1,(3))”) in new stack
[2020-11-20 13:53:10] WARNING[31087][C-000005c6]: chan_iax2.c:5839 ast_iax2_new: No formats specified for call to: IAX2/YREKA-6675
[2020-11-20 13:53:10] WARNING[31087][C-000005c6]: app_dial.c:2576 dial_exec_full: Unable to create channel of type ‘IAX2’ (cause 0 - Unknown)
– No devices or endpoints to dial (technology/resource)
– Executing [s@macro-dialout-trunk:35] NoOp(“SIP/2051-00000700”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 0”) in new stack
– Executing [s@macro-dialout-trunk:36] GotoIf(“SIP/2051-00000700”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [s-CHANUNAVAIL@macro-dialout-trunk:1] Set(“SIP/2051-00000700”, “RC=0”) in new stack
– Executing [s-CHANUNAVAIL@macro-dialout-trunk:2] Goto(“SIP/2051-00000700”, “0,1”) in new stack
– Goto (macro-dialout-trunk,0,1)
– Executing [0@macro-dialout-trunk:1] Goto(“SIP/2051-00000700”, “continue,1”) in new stack
– Goto (macro-dialout-trunk,continue,1)
– Executing [continue@macro-dialout-trunk:1] NoOp(“SIP/2051-00000700”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 0 - failing through to other trunks”) in new stack
– Executing [continue@macro-dialout-trunk:2] ExecIf(“SIP/2051-00000700”, “1?Set(CALLERID(number)=2051)”) in new stack
– Executing [7048@from-internal:12] Macro(“SIP/2051-00000700”, “outisbusy,”) in new stack
– Executing [s@macro-outisbusy:1] Progress(“SIP/2051-00000700”, “”) in new stack
– Executing [s@macro-outisbusy:2] GotoIf(“SIP/2051-00000700”, “0?emergency,1”) in new stack
– Executing [s@macro-outisbusy:3] GotoIf(“SIP/2051-00000700”, “0?intracompany,1”) in new stack
– Executing [s@macro-outisbusy:4] Playback(“SIP/2051-00000700”, “all-circuits-busy-now&please-try-call-later, noanswer”) in new stack
– <SIP/2051-00000700> Playing ‘all-circuits-busy-now.ulaw’ (language ‘en’)
– <SIP/2051-00000700> Playing ‘please-try-call-later.ulaw’ (language ‘en’)
– Executing [h@from-internal:1] Macro(“SIP/2051-00000700”, “hangupcall”) in new stack
– Executing [s@macro-hangupcall:1] GotoIf(“SIP/2051-00000700”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)


(Dave Burgess) #2

Google Foo says that you have an unmatched Codec, probably one of the new ones like Silk. Make sure you are using supported codecs like ulaw or alaw (depending on your local preferences).


(River Tek) #3

Thank you for the quick response!

Both servers have only ulaw, alaw, and gsm checked which is also something we checked. All other codecs are unchecked.

You’re not going to believe this or maybe you will, without making any changes I simply hit the ‘Submit’ and ‘Apply’ button on the IAX Settings tab and it’s now working. Thanks Dave for leading me back to those settings!


(Dave Burgess) #4

No victory lap yet. If it works for (say) 24 hours and stops working, there are other (usually routing) errors in play that can make this unreliable.

Let us know if the problem that went away by itself comes back by itself. :wink: