FreePBX | Register | Issues | Wiki | Portal | Support

IAX Configuration Questions


#1

Hello,

Can you call a ring group accross the IAX connection to a ring group on the other server?

Example:

Ext 100 calls Ext 200 across the IAX ( WORKS )
Ext 100 calls Ring Group 2200 accross the IAX ( FAILS )

Not sure if this is by design, I tried this from a few different versions of PBX with the same results.

The goal is getting extensions to be able to call ring groups on the other PBX.

Any insight appreciated!

Thanks!


#2

At the calling end, you need an Outbound Route that matches 2200 and selects the IAX trunk.

On the receiving end, the context for the IAX trunk should be from-internal .

If no luck, post what the caller hears, and logs from both systems for the same failing call.


#3

Yes, the call pattern on the outbound route to the IAX has 2xx as well as specifically 2200, I know I can use 2xxx, but there are potentially some 2XXX groups on the local pbx ( PBX1 ) but none conflicting of course.

They get an all circuits busy message when calling the ring group accross.
PBX2 doesn’t show the call attempt on the CDR.

Additionally the local caller Ext 100 (PBX1) does have access to the route.

When I tried to do some IAX debugging I did see this on the calling PBX (PBX1):

Tx-Frame Retry[000] – OSeqno: 001 ISeqno: 001 Type: IAX Subclass: AUTHREP
Timestamp: 00063ms SCall: 27164 DCall: 11837 [10.17.252.10:4569]
MD5 RESULT : 765e150a97bc258b9c77f58de12563e5

Rx-Frame Retry[ No] – OSeqno: 001 ISeqno: 002 Type: IAX Subclass: REJECT
Timestamp: 00038ms SCall: 11837 DCall: 27164 [10.17.252.10:4569]
CAUSE : No such context/extension
CAUSE CODE : 3

[2019-08-07 17:11:04] WARNING[3372]: chan_iax2.c:10765 socket_process: Call rejected by 10.17.252.10: No such context/extension
[2019-08-07 17:11:04] WARNING[3372]: chan_iax2.c:10765 socket_process: Call rejected by 10.17.252.10: No such context/extension
Tx-Frame Retry[-01] – OSeqno: 002 ISeqno: 002 Type: IAX Subclass: ACK

And it says no such extension, of course it’s a ring group local to PBX2

Thanks!


#4

Confirm that the context is from-internal on the trunk at PBX2. It that’s correct (or fixing it doesn’t help), post the Asterisk log on PBX2 for the failing call.


(Chris Dolese) #5

are the trunks flagged intra-company ?
also take the ring groups out of the picture - can you make a call across the iax trunk successfully ?


#6

Hello All,

It looks like the context=from-internal is making the difference.
The calls to extensions was working perfectly, but to ring groups was not.
(For reference context=default was what we were using before, this is in the inbound IAX configuration.)

Thank you!


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.