I changed extensions from sip to pjsip and Mark Answered Elsewhere does not work anymore


(Greece) #1

After I changed extensions from sip to pjsip and Mark Answered Elsewhere does not work anymore.
My phones are Cisco SPA504G and SPA303.
No other problems.
Any help?
Thank you!


(Dave Burgess) #2

There was a lot of discussion about this about a year ago (Covid makes all time seem compressed). I don’t even remember if we ever came to a conclusion on any of it, but I’m pretty sure we discussed this at length.


(Greece) #3

About a year ago there was the same problem because of a bug in a module. After it was updated it worked again.

In freePBX the only setting is Mark Answered Elsewhere in Inbound Route?
Is there some other setting that affects it in Inbound route or in freePBX/Extensions?
Could there be relevant settings in phone?

Thank you!


(Jared Busch) #4

It has to be the phones or their implementation of SIP. Because that function works fine with Yealink and Fanvil phones.


(Charles Darwin) #5

I had the same problem with Cisco 8961 phones. I had to use an older firmware to make it work again. But the older firmware had other issues. …it is definitely a bug in Ciscos SIP firmware, because the older versions can handle “answered elsewhere”. You could try to go back to the future with your Ciscos… :wink:
The better solution would be to buy some REAL sip phones…

EDIT: I did not use pjsip…just sip…


(Greece) #6

Charles_Darwin, with sip Mark Answered Elsewere worked with my Cisco phones.

Could you please suggest me some better sip phones?


(Charles Darwin) #7

Sorry for being late…

I am no expert…I have been using Cisco phones for 15 years or so. Great hardware, terrible SIP firmware! The Cisco phones I used, 7975 and 8961, needed an Asterisk patch to get BLF-functionality, which is a minimum requirement for a phone system…
The problem is that freePBX does not fully support ANY phone out of the box. I think…for a long time…that was actually part of the business model of Sangoma. Give freePBX for free to customers…let them fool around…let them think that the phone system works…let them install it in a productive setting…and charge them for very expensive online support afterwards :wink:

I tested a Sangoma s705 phone, because I didnt want to mess with Asterisk anymore. I was very disappointed! Bad audio quality (I use g722) and terrible phone apps…not to forget the low quality phone screen.
I tested a Digium/Sangoma D65 phone and liked it very much. With freePBX it is a bit complicated to use all features. The advanced DPMA configuration with xml-files for all phones is required, but once set up it works great and 100% stable…including “mark answered elsewhere” :wink:


(Greece) #8

Maybe my problem with “Marked Aswered Elsewhere” has to do with these bugs of previous versions? Maybe the bug still exists?
15.0.11.8: #21311 Ring Groups module, Mark Answered Elsewhere problem
15.0.11.7: #19795 Mark Answered Elsewhere broken after updating

I am using latest Ring group 15.0.11.9.