I can't register my mobile phone

I am new to pbx setups. I have a voip account with a provider and I wanted to setup a freepbx to use TCP transport mode with my mobile.(battery drain is horrible on UDP)
I was using pbxes services for a little while so I tried configuring freepbx in the same way; I configure a trunk to my sip provider and it went fine.(My pbx is registered in their server) I also created an extension and there was an error with the fax module.(Since I didn’t want to use fax with this line I disabled the fax module) I created an inbound route to my extension# and an outbound route.
The problem is that I can’t register my mobile on my pbx. I used media5 and csipsimple softwares for android. Both of them use to be able to register on pbxes.
Can you help me. Have I forgotton to setup something?
I have version freepbx and asterisk.

p.s. As I am previewing my post I see that the date is set to 1969!..Could it be the problem?

What exactly fails? Have you reviewed the asterisk logs?

I have two cell phones with linphone and created two extensions within freepbx and set this up within linphone. Simple.

How did you determine udp drains your battery faster than TCP?

I am unable to register my mobile.
Actually I just did register but I lost registration a minute later after I tried to place a call (which didn’t connect)
I went to check the logs as you suggested. Here are the last asterisk lines starting from the one just before I finally obtained registration.

[Jul 10 18:53:23] VERBOSE[2798] chan_sip.c: – Registered SIP ‘100’ at port 44893
[Jul 10 18:53:24] NOTICE[2798] chan_sip.c: Peer ‘100’ is now Reachable. (63ms / 2000ms)
[Jul 10 18:53:26] VERBOSE[3023] manager.c: == Manager ‘admin’ logged on from
[Jul 10 18:53:26] VERBOSE[3023] manager.c: == Manager ‘admin’ logged off from
[Jul 10 18:55:28] NOTICE[2798] chan_sip.c: Peer ‘100’ is now UNREACHABLE! Last qualify: 47
[Jul 10 18:56:17] VERBOSE[3033] manager.c: == Manager ‘admin’ logged on from
[Jul 10 18:56:17] VERBOSE[3033] manager.c: == Manager ‘admin’ logged off from
[Jul 10 18:56:19] VERBOSE[3035] manager.c: == Manager ‘admin’ logged on from

By the way, how come the date and time is wrong?..

As for UDP and TCP battery, I had a chance to experiment with sipdroid and pbxes when I started using my cell for voip calls. I noticed that TCP was easier on the battery than UDP. I also documented myself on the subjet on the web.

I have seen that error when my phone’s SIP client is closed and/or inactive but it does not happen within two minutes. Have you tried a different SIP client? Do you have any actual desk phones or all soft phones? Are all extensions three digits?

I have tried with Bria, media5, csipsimple, and sipdroid. Sipdroid was the only one that gave me a registration. The one in the logs.
I have only one extension and that is for my mobile softphone. My extension is 100.