I can't forward external calls to PSTN numbers (internal calls are OK)

Hello everyone.

I am setting up a small PBX (FreePBX 12.0.25 - Asterisk 11.15.0) on an old PC (Celeron 325 512 mb Ram).
I installed FreePBX and the actual configuration is as follows:

One trunk for outgoing calls only (no phone number connected to it)
One trunk for incoming calls only (of course i have one phone number on this one, but no outgoing calling capability)

Two sip extensions
One ring group that contains only my cell phone number followed by #

One inbound route from the incoming trunk to whatever i choose
One outbound route using the outgoing trunk.

I can make calls from my sip extensions to external phone numbers.
I can make calls from one sip extension to the other or to the ring group (in this case my cell phone rings).
When i set a sip extension to be the target of the inbound route, if someone calls the number, I receive the call.

So far so good… here comes the issue.

If I set the ring group to be the target of the inbound route, the incoming call does not get through (to be more specific, the caller hears two tones and then the call is hung)

I have found googling that for a very similar problem (http://forums.asterisk.org/viewtopic.php?f=1&t=77231) someone solved the issue by setting outbound caller ID to “Block Foreing CID’s”.
That, of course, didn’t work for me.

Any idea on what should i check first?

I was wondering… could the problem be that i am trying to pass the call from one trunk to the other?

And that the two trunks are somehow isolated, like say, in two different context?
I don’t think this is the case but, given the low experience i have with Asterisk, i am just guessing…

Are you sure is not a problem with the ring group?
I’m currently having a similar problem, if I forward an incoming call to a ring group it always hangup, well, actually it always goes directly to the action you setup in the “destination if no answer”.

If I forward the call to an extension then it works.
Maybe a problem with the latest freepbx…

I too have seen where the original (calling) parties CID is being passed through to the outbound trunks, some providers will not allow the call to go through if that happens, you could always try FORCING the caller ID to a set value on the outbound route, the value being one of the DID’s from the provider for the trunk you’re dialing out on and see if that changes the result.

I’ve seen where some providers will block calls not from a registered CID. I think that manageddc might be on to something.

Thanks for your input.

I don’t think it’s the ring group, it does not work even with the “follow me” settings, i’ll look into it anyway.

I am starting to think that there is something wrong with my outbound trunk too, i will try manageddc’s advice.
I am also setting up a trunk with another provider to see if this solves the problem.

Brief update.

I tried forcing the caller ID on the trunk to a set value with no result.
I also added a trunk from another operator to use instead of the old one but again with no result.

It’s becoming quite frustrating…

You may have already tried this, but let’s just be sure.
You need to eliminate some of the variables and narrow down the problem.
Create a group with just one of your sip extensions and see if that works.
If so, then change the group to have only the other extension.
Then add both.
Repeat the process with just your cell. then build from there.

I gave it another try just to be sure.

The group with just one or both the sip extensions worked from an external call and from internal calls.
When i put just the classic phone number in the group, it stops working for external calls but keeps working for internal calls (i.e. if i dial 602 from a sip extension, my destination classical phone rings).

Of course if in the group there are sip extensions and the classic phone number, on receiving an external call only the sip extensions ring.

If by classical you mean cell phone - and you’ve got it set up as an extension - (602)
How did you do that?

I think you may be trying to use a feature code or ring group inside your other ring group to call the cell.
I tried that scenario here and it doesn’t work for me. What does work is putting the actual cell number followed by the #
You can still use the misc app & misc destination as a short cut for your internal extensions.


No i have not set the classical (yes this is the cellphone) as an extension, i just put the number in the ring group followed by the # as you say,

Since you mentioned it, i was playing with misc destinations, that is a feature i didn’t try earlier.

If i insert an extension or ring group in the misc destination, it works (or does not work) exactly as if i targeted the extension or ring group directly from the incoming trunk.
If i put a phone number to be dialed (the cell number), i get a “call cannot be completed as dialed” message.
Is there a particular syntax to follow?

I still have the problem.
Any further advice for me?


I don’t mean to state the obvious…but do you have more than one trunk? If you only have one trunk active then the incoming call will tie it up and you will not be able to forward outside while that trunk is busy.


sorry boss,
but if any one can help me about create a sip trunk for external call use, it will be really a great help for me.

actually i have a (grandstream ht-503) fxo-fxs device. i want to use our local analogue pstn telephone line in asterisk by using the ** fxo port** for external call in to asterisk via the IVR & want to call external by any prefix from any sip extension.

pls help me…