I can not apply the settings. Ubuntu 16.04 + php7 + FreePBX 14

Notifications:
Critical: retrieve_conf failed, config not applied
Reload failed because retrieve_conf encountered an error: 1

к

exit: 1
Whoops\Exception\ErrorException: Methods with the same name as their class will not be constructors in a future version of PHP; modulelist has a deprecated constructor in file /var/www/html/admin/libraries/modulelist.class.php on line 3
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/modulelist.class.php:3
  2. Whoops\Run->handleError() /var/www/html/admin/functions.inc.php:180
  3. require_once() /var/www/html/admin/functions.inc.php:180
  4. fpbx_framework_autoloader() :0
  5. spl_autoload_call() /var/www/html/admin/libraries/modulefunctions.class.php:636
  6. module_functions->getinfo() /var/www/html/admin/libraries/utility.functions.php:1350
  7. _bootstrap_parse_hooks() /var/www/html/admin/libraries/utility.functions.php:1326
  8. bootstrap_include_hooks() /var/www/html/admin/bootstrap.php:304
  9. require_once() /etc/freepbx.conf:9
  10. include_once() /var/lib/asterisk/bin/retrieve_conf:9

Sounds like you’re trying to run FreePBX 13 on PHP7. You need FreePBX 14 for that (You’ll have to manually pull it from git)

Did not work out. Log FreePBX 14:
exit: 1
Whoops\Exception\ErrorException: Methods with the same name as their class will not be constructors in a future version of PHP; modulelist has a deprecated constructor in file /var/www/html/admin/libraries/modulelist.class.php on line 3
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/modulelist.class.php:3
  2. Whoops\Run->handleError() /var/www/html/admin/functions.inc.php:180
  3. require_once() /var/www/html/admin/functions.inc.php:180
  4. fpbx_framework_autoloader() [internal]:0
  5. spl_autoload_call() /var/www/html/admin/libraries/modulefunctions.class.php:645
  6. module_functions->getinfo() /var/www/html/admin/libraries/utility.functions.php:1350
  7. _bootstrap_parse_hooks() /var/www/html/admin/libraries/utility.functions.php:1326
  8. bootstrap_include_hooks() /var/www/html/admin/bootstrap.php:289
  9. require_once() /etc/freepbx.conf:9
  10. include_once() /var/lib/asterisk/bin/retrieve_conf:9

I’ve just done a couple of commits to the freepbx 14 branch that fixes at least that error (and removes some more php4-isms), so give that a shot and if you get any more issues, we can fix them too!

Thanks!

I can try to work with renewed FreePBX 14

I can download link FreePBX 14 http://mirror.freepbx.org/modules/packages/freepbx/freepbx-14.0-latest.tgz

Yes, that has been updated with 14.0.20, which has those fixes in it.

If you’re going to be using bleeding-edge software, I suggest you set up a Development Environment, as per the wiki guide:

http://wiki.freepbx.org/display/FOP/Setting+Up+a+Development+Environment

That’s the error

exit: 1
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Unable to access the running directory (Permission denied). Changing to ‘/’ for compatibility.
Whoops\Exception\ErrorException: Non-static method connectdirs::create() should not be called statically in file /var/lib/asterisk/bin/retrieve_conf on line 488
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/lib/asterisk/bin/retrieve_conf:488
  2. Whoops\Run->handleError() /var/lib/asterisk/bin/retrieve_conf:488

Notifications:

Critical: retrieve_conf failed, config not applied
Reload failed because retrieve_conf encountered an error: 1

Pressed on Module link

drwxr-xr-x 3 asterisk asterisk 4096 Aug 17 23:40 ./
drwxr-xr-x 3 asterisk asterisk 4096 Aug 17 07:35 …/
d-wxr-xr-T 9 asterisk asterisk 4096 Aug 17 23:30 admin/
-rw-r–r-- 1 asterisk asterisk 453 Aug 17 15:39 index.php
-rw-r–r-- 1 asterisk asterisk 361 Aug 17 15:39 robots.txt

User asterisk … Underneath runs Apache 2 and Asterisk 13

After opening the link modules, all URL on the site http://192.168.168.115/ an error from php

The permissions on /var/www/html/admin/modules:

d-wxr-xr-T 18 asterisk asterisk 4096 Aug 17 23:30 modules/

d-wxr-xr-T 18 asterisk asterisk 4096 Aug 17 23:30 ./
d-wxr-xr-T 9 asterisk asterisk 4096 Aug 17 23:30 …/
drwxr-xr-x 2 asterisk asterisk 4096 Aug 17 23:30 _cache/
d-wxr-xr-T 6 asterisk asterisk 4096 Aug 17 23:29 callrecording/
d-wxr-xr-T 6 asterisk asterisk 4096 Aug 17 23:29 cdr/
d-wxr-xr-T 7 asterisk asterisk 4096 Aug 17 23:29 cel/
d-wxr-xr-T 10 asterisk asterisk 4096 Aug 17 23:29 core/
d-wxr-xr-T 5 asterisk asterisk 4096 Aug 17 23:29 customappsreg/
d-wxr-xr-T 8 asterisk asterisk 4096 Aug 17 23:29 dashboard/
d-wxr-xr-T 5 asterisk asterisk 4096 Aug 17 23:29 featurecodeadmin/
d-wxr-xr-T 3 asterisk asterisk 4096 Aug 17 23:30 framework/
d-wxr-xr-T 3 asterisk asterisk 4096 Aug 17 23:29 infoservices/
d-wxr-xr-T 6 asterisk asterisk 4096 Aug 17 23:29 logfiles/
d-wxr-xr-T 5 asterisk asterisk 4096 Aug 17 23:29 music/
d-wxr-xr-T 5 asterisk asterisk 4096 Aug 17 23:29 sipsettings/
d-wxr-xr-T 7 asterisk asterisk 4096 Aug 17 23:30 ucp/
d-wxr-xr-T 8 asterisk asterisk 4096 Aug 17 23:29 userman/
d-wxr-xr-T 6 asterisk asterisk 4096 Aug 17 23:29 voicemail/

Your permissions are all messed up. Please run ‘fwconsole chown’.

[email protected]:~# fwconsole chown
Whoops\Exception\ErrorException: Declaration of FreePBX\Console\Application\FWHelpCommand::setCommand($command) should be compatible with Symfony\Component\Console\Command\HelpCommand::setCommand(Symfony\Component\Console\Command\Command $command) in file /var/www/html/admin/libraries/FWHelper.class.php on line 15
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/FWHelper.class.php:15
  2. Whoops\Run->handleError() /var/www/html/admin/libraries/FWHelper.class.php:15
  3. include() /var/lib/asterisk/bin/fwconsole:69

Lower your error reporting level or use php 5.6

php.ini
error_reporting = 0

Errors are repeated.

Question. What you test platform for Free PBH 13, 14. What is the distribution version of php, Muskl, Apache?

You need to lower the error level through freepbx. It’s a config file option. Search the wiki.

Please! Show me! I can not find! I tried to add in the “freepbx.conf”
$amp_conf[‘PHP_ERROR_LEVEL’]=0;
$amp_conf[‘PHPERRORLEVEL’]=0;

In amportal.conf:
PHP_ERROR_LEVEL=0

What am I doing wrong?

(Ubuntu 16.04, FreePBX14, php7.0)

As previously suggested. Search the wiki. Everything you’ve done there is completely made up.

http://wiki.freepbx.org/display/FOP/Turning+off+FreePBX+Error+Handling