I can call extension to extension but could not hear the voice

I have really big issues when I can’t hear both side when calling SIP extension to SIP extension. There is an echo when I try to talk. My headset & PC microphone volume is set to high already. Isn’t because any firewall block the voice? Anybody please help me.

Hmm, if you could provide some more information, it’ll help us both.
Are these SIP extns on the same network ? Are you running this through FreePBX ? Are you calling from softphone to softphone, or to a SIP phone (Polycom, Linksys, etc). What settings have you changed on your firewall to accomodate SIP traffic ?

The following is taken from Nerd Vittles:

It’s Your Firewall, Stupid.
I wish I had a nickel for every message thread that has been written that goes something like this. “I can make calls out of my system, but the people I call can’t hear me.” Or vice versa. The answer is pretty simple if you stop and think about it for a second. A phone call has two participants. One talks and the other one listens. Then you take turns. At least that’s the theory. For that to actually work in the world of Internet telephony, the talking legs of the call have to be able to get from Point A to Point B and from Point B to Point A. If your IP-based telephone or Asterisk system is sitting behind a firewall/router, you have to configure your router to pass the incoming data into the server and telephone on your private network. If the telephone or Asterisk system on the other end of the call happens to also be sitting behind a firewall/router, then we have what’s called “double NAT issues.” And, no, this doesn’t refer to no-see-ums on a steamy summer night in Dixie. Bottom line: If any of this communications traffic can’t find it’s way to the other end, then someone can’t hear all or part of the telephone conversation.

To fix NAT problems with Asterisk, you simply tell your router to forward all data received on UDP ports 4569, 5004 to 5037, 5039 to 5082, and 10000 to 20000 to the private IP address of your Asterisk server. You also must make certain that the following entries exist in /etc/asterisk/rtp.conf:


And bindport = 5060 must exist in the [general] context of /etc/asterisk/sip.conf. The aggregations take care of the rtp.conf and sip.conf setups for you. But you must reconfigure your router/firewall. Last, but not least, you probably need to complete the next step below as well.

It’s a good idea to read the remainder of the article, as it will undoubtably provide with some more gems on how to setup your infrastructure

Good Luck !

I’m actually using FreePBX and connect the two extension using same network. I use softphone (3CX) to make the call. Thanks for help magpye (tadpole) :slight_smile:

Ok, here’s something you can try to further pinpoint the issue.
Disable any firewalls on your PC’s for the testing period.
Then dial the other SIP client via it’s IP address instead of it’s extension.
See if you still have audio problems and echo.

If it does, chances are your network, probably your router, is either not configured properly or doesn’t know how to act around SIP packets.
If it doesn’t, then you’ll need to look at the conf files in FreePBX.
Again, that article will handhold you through the required settings…

If the two extensions are on the same network the router is not looking at the RDP data is either bridged or switched depending on if he is using a hub or a switch.

The firewall on the PC is a good theory. Run the echo test on each extension and see if you can hear yourself. The default echo test code is *43

Is the FreePBX system also in the same network?

I can’t run echo test. There is not unavailable, I already check the feature codes in FreePBX and state the echo test is *43. I’m also use FreePBX system in same network. Do you know how to dial using IP instead of the extension?

Installed new AsteriskNOW Beta 1.5 (FreePBX, setup two extensions, set up 2 softphones-(X-lite), 1 each on 2 different
computers. they register with the server okay., and they can’t call each other, or run the echo test… After awhile the message says “the person you are calling is unavailable, please try again” no calls have been registered through the FreePBX interface. All computers, 1 with AsteriskNOW, 1 with X-lite and another with X-lite are all on the same LAN…

and none have a firewall installed on them up and running? firewalls do strange things like block traffic…

Correct the firewall is disabled on the Windows/Vista PC with X-lite and the linux server running AsteriskNOW Beta 1.5

The problem was that the #include statements are missing from the sip.conf file for files like sip_additional.conf which is where FreePBX writes the extensions that are defined in the browser interface. Can anyone tell me how this happened? I see a file “sip.conf.rpmorig” that still has the #includes in it.

I fixed the problem by manually taking the extension description out of the sip_additional.conf file and adding it to sip.conf then restarted asterisk and the X-lite registered okay. The extension was defined as far as asterisk was concerned even though it showed up in the FreePBX interface.

Spread the word, this was a confusing problem to solve!

I meant to say, “the extension was “NOT” defined as far as asterisk was concerned even though it showed up in the FreePBX interface.”

sorry in a hurry.

fyi: Here is what the sip.conf file should look like.

; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
; jbenable=yes
; jbforce=yes

; These will all be included in the [general] context
#include sip_general_additional.conf
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf

; These should all be expected to come after the [general] context
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf