I broke my admin web interface - help!

Short story - I jacked up the admin ports in the gui under system admin so I cant get back to it. Is there a config file i can edit (even temporarily) to get me back into the GUI, or how to do I fix it?)

Long story - So, my client wants to use QueueMetrics. Its installed - and works fine. however, the web interface is on port 8080 and is only accessible from the “trusted” machine that is excluded from firewall rules. None of the other machines on the LAN (LAN is set to local traffic trusted in the firewall). We access the admin portal on port 85 (http) - long story, had to do with Zulu… I was trying to avoid making custom firewall rules to allow in port 8080… so I stupidly added in 8080 as the https secure for the admin portal (replacing the 443 that I wasn’t using anyway). Now, the admin web interface says connection refused (on port 85), so I cant get back in to undo this change. Trying 8080 or https gives me a 404 not found error.

I still have putty ssh access - is there some config file I can make the change in - even temporarily - to get back in and fix the admin portal? Below is the screen shot from the wiki (not mine!) - in mine the “insecure port” is port 85 - and the secure port is 8080 now… it was 443 - and I figured I wasn’t using it because we use 85. How can I revert it, and bonus points for how can I add 8080 to the list of open ports in the firewall… Sorry - thanks in advance…

First the easy part:

See this page: https://wiki.freepbx.org/display/FPG/Firewall+Services#FirewallServices-CustomServicesTab

For your Apache misconifg, you need to edit the files (maybe after getting a backup first):

 /etc/httpd/conf.d/schmoozecom.conf
 /etc/httpd/conf.d/ssl.conf

you shouldn’t have to edit anything other than the bad port numbers, change them to something that doesn’t conflict. Save the files and restart Apache:

service httpd restart

With luck the service will restart and allow access to System Admin so you can re-save your settings there.

1 Like

Wow. Once again Lorne you have saved my hide… I just went into the ssl.conf and changed all the 8080 to 443 and restarted and I was right back in. I then went back into system admin and changed the 8080 back to 443, applied, and Im still in… thank you so much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.