Huge Issue: SPA 303 All Extentions Default to 1

So I have a huge issue.

I have 6 Cisco SPA303 configured and working.

Each phone has 3 lines setup for it. The first line is the main line with voicemail and used as a standard extension.

The other two lines are setup on silent so everybody in the office can see who is calling and pickup the call.

However, EVERY time the phone resets it changes it setup from:
Line Key 1 -> Extention: 1
Line Key 2 -> Extention: 2
Line Key 3 -> Extention: 3

Line Key 1 -> Extention: 1
Line Key 2 -> Extention: 1
Line Key 3 -> Extention: 1

It must be pulling it’s configuration from the EndPointManager.

I have tried going through it and making changes but it is no use.

In order to fix this I need to go to each phone’s web admin and change the line key settings after EVERY reboot.

I am using:
PBX End Point Manager by Andrew Nagy
FreePBX i
CentOS 32 bit

For those using Cisco SPA 303 Phones.

I figured out simple workaround.

From the phones web interface:
Admin -> Advanced -> Provsioning

Just set provisioning to “No”

This will prevent your phone from downloading the incorrect config and setting all of it’s extensions to 1.

This appears to be a bug in the “Endpoint Configurator”

I the problem is that the configs provided with the EPM don’t work for you why not just change then to suite your needs?

I have tried editing spa$mac.xml

I found what I think is the function which controls the lines:

Unit_1_Key_{$number} group=“Attendant_Console/Unit_1” {$data} /Unit_1_Key_{$number}
Unit_2_Key_{$number} group=“Attendant_Console/Unit_2” {$data} /Unit_2_Key_{$number}

However, making changes did not actually affect anything on the phone.

Maybe I’m missing something.

Thats the wrong area. Look at the first few lines of that file. The part you were editing is the extension units that you dont appear to have