Https is serving stale/expired letsencrypt cert

configuration
Tags: #<Tag:0x00007f7023358a78>

(Elliott Walsh) #1

I’ve succeeded at updating my LE cert in ‘Certificate Management’, and set it as default. I’ve also gone to ‘System Admin’>‘HTTPS Setup’>‘Settings’, and succeeded at selecting the new cert, and configuring Apache to use it. However, in my browsers (Firefox, Chrome, Edge), the site continues to show it is serving an expired LE cert from early last year. I’m baffled as to why this is happening. Sysadmin RPM is the most current. This pbx server runs in the DMZ with the firewall enabled, if that could be a factor. I’m out of ideas, and need some insight.


(Itzik) #2

Try restarting apache and clear browser cache.


(Jared Busch) #3

Always verify browser issues by using private mode from a browser that you have not recently used with the PBX.


(Elliott Walsh) #4

Thank you for helping. I did try those, and still getting the old certificate.


(Elliott Walsh) #5

Thank you, but that hasn’t made any difference.