Http port changed with module update

Just a heads up I updated my modules including sys admin to 14.0.39.55 and my http port went from 85 to 8088 which caused issues and shut apache down. I manually changed the http listen port and everything was good. Not sure if it is something in the latest sys admin release or just a fluke

Where are you changing - in sysadmin or directly in the config files?

config files rewrote themselves to listen on port 8088. Changed it there and restarted apache

Best to set the port in sysadmin.

Sysadmin owns the httpd config, just like the asterisk config files. If your directly editing the files in /etc/httpd, this will be a recurring problem. It’s possible to do some manual config, but you have to make sure it plays nicely with sysadmin.

1 Like

Hi Mark

Can you confirm please, you are using the System Admin module to change from the default apache ports, and the module upgrade changed them? Which service, the admin gui?

1 Like

After the update I lost http and it wouldn’t start at the root level. I then entered the config files and manually changed because apache was down. I agree sysadmin is typically the best place to change it.

When the system was installed I changed http to 85 so I could use 80 for Zulu/LE. I accessed the system on port 85 this morning as there some queue issues. I then decided to update the modules. After updating the module apache was down and found out the listen port changed in the update

[[email protected] ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset                                                                : disabled)
   Active: failed (Result: exit-code) since Tue 2021-02-02 12:13:32 EST; 6min ag                                                                o
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 26039 (code=exited, status=1/FAILURE)
   Status: "Total requests: 7513; Current requests/sec: 0.2; Current traffic: 1.                                                                1KB/sec"

At this point I would:

  1. Go into sysadmin, make sure the ports match what you want (sysadmin does NOT get info from the /etc/httpd files).
  2. Save the changes
  3. systemctl restart httpd

If everything works, try rolling back to the previous sysadmin version, test, upgrade again, test.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.