Howto install "boss secretary" module

I have found a link for adding “boss secretary” functionality to FreePBX : http://issues.freepbx.org/browse/FREEPBX-3906?jql=text%20~%20"boss%20secretary%20module"

Is there a procedure howto install this module ? It doesn’t appear in any of the standard or commercial modules, so it is a kind of add-on to install manually?

You can get it from the download link on this page:
http://git.freepbx.org/projects/FPBXCN/repos/bosssecretary/browse

Be prepared for the chance that it won’t work in FreePBX 13, it has hardly been touched in years.

I did find the contribution library, but is there any procedure howto install those ?

http://wiki.freepbx.org/display/FPG/Download+and+Installing+Custom+Modules

ok - thanks a lot :slight_smile:

1 Like

hi again,

The boss secretary module was in ZIP format, so I converted to TAR and on my WIndows PC it makes the file type .TAR, not .tar. I tried to upload it via module admin, but this fails: .tar expected and not .TAR ?

I managed to install the module directly on the server in the var/www/html/admin/modules folder. And then it becomes visible in de admin gui for activating it. Works like a charm :slight_smile:

Weird that the boss-secretary module is provided in not supported ZIP format, and that neither of the .TAR, GZ,… formats are accepted to upload it with the FreePBX Module Admin on a WIndows PC.

The module seems to work only for INTERNAL calls. When an EXTERNAL caller calls the boss, then his extension will ring normally and not the secretary. So I assume that the from-trunk context does not include the module ?

I managed to make it work by modifying the core extensions.conf file in var/html/admin/modules/core/etc. I have added “include => ext-bosssecretary” in the from-did-direct context. But offcourse this wil disappear when I need to upgrade FreePBX modules in the future. Is there another way to include the ext-bosssecreatary into the inbound dialplan ? I tried via custom conf files and even with the custom contexts configuration in the Connectivity tab of FreePBX GUI, but without success.

Another problem is that when assigning a BLF for the Boss Secretary toggle function, it keeps on showing the idle status, even when activated. There is a Notify sent to the subcribed extension, but it shows always “terminated” in the message body state field for both the ON and OFF status.

Add it to extensions_custom.conf

[from-did-direct]
include => ext-bosssecretary

*edit - this module has been abandoned and does not appear to be in common usage, so if it doesn’t work as expected you may be out of luck.

Looking at the description of what boss/secretary module actually does, I have a feeling you could replicate that functionality with ‘just’ an appropriately configured queue :wink: (since b/s module itself creates a ring group) (just be sure to put all the ‘secretaries’ extensions before the ‘boss’ ones)

Tx Lorne - it’s working now. I did what you suggest in a slightly different way before, because I had already a extension_custom.conf file for DID number stripping like this:

[DIDmapping]
; removes the DID prefix before routing a DID call to an extension
include => from-did-direct

That’s why I thought to change it it his way:

[DIDmapping]
; removes the DID prefix before routing a DID call to an extension
include => ext-bosssecretary
include => from-did-direct

because the from-did-direct context already exists in the core extensions.conf, but this didn’t work.

So finally I did what you suggest:

[DIDmapping]
; removes the DID prefix before routing a DID call to an extension
include => from-did-direct

[from-did-direct]
include => ext-bosssecretary

and this is working :slight_smile: so it means that in extensions-custom.conf you can define already existing contexts and add includes in it - that’s great - I did not know this.

I think it’s a pitty that this module is abandoned - it’s a very nice feature used a lot in Europe. The suggestion of el_es does only partly solve the issue as ringing of the boss is not silent and also the overruling by “chiefs” is missing.

With more than 250 views already it is maybe time to reconsider the module ?

1 Like

So now I’m only stuck with the BLF toggling. This is the Asterisk trace giving an error on DEVSTATE:

– Executing [[email protected]:9] Set(“SIP/42-00000011”, “STATE=BUSY”) in new stack
** – Executing [[email protected]:10] Gosub(“SIP/42-00000011”, “app-bosssecretary-toggle,sstate,1()”) in new stack

** – Executing [[email protected]:1] Set(“SIP/42-00000011”, “DEVSTATE(Custom:BSC1)=BUSY”) in new stack**
[2016-10-26 11:37:02] ERROR[2236]: pbx.c:4224 ast_func_write: Function DEVSTATE not registered

I have set in FreePBX the Enable Custom Device States to TRUE, and these are the hints:

             *[email protected]: Custom:BSC1           State:Idle            Watchers  1
             *[email protected]: Custom:BSC1           State:Idle            Watchers  0

where *152 is the toggle feature code and 41 and 42 are the boss and secretary extensions. As mentioned before, the State remains Idle and the NOTIFY sends always “terminated”.

Anyone who knows why “Function DEVSTATE not registered” is coming ? Is the hint *152XX" the problem maybe ? XX is the extension (boss or secretary) who subscibed. If I only put in *152 in the IPPhone BLF, then I’m not even getting a NOTIFY, but with *15241 and *15242 I’m getting them, but always “terminated” (idle)