How would you troubleshoot a Sangoma phone that will not provision

For the record all brands of my phones will not talk to the server. But this post is more about how I should go about troubleshooting this problem. Out of nowhere, and I mean it worked yesterday and today it doesn’t(a week ago). None of the phones will provision after I made some extension changes. I can’t reset the S series phones from end point manager, They load up blank after a factory reset. My normal method is to constantly reinstall FreePBX from scratch and even that crashes several times before it works. I had this server running for years with zero issues and now I’m like a lost cause and can’t get anything to function.

I did pay for support and they pretty much telling me I’m an idiot and everything is fine. I am an idiot, but everything is not fine :rofl::sob:. I have tried this with my routers firewall on and with it off, I’ve connected the phones directly to the modem. There are settings in End Point Manager that all look fine to me. Isn’t there logs to see? If everything is default in the server settings it should just work like last time this server functioned.

This is from End Point Manager

Aor: 20001 5

ParameterName : ParameterValue

authenticate_qualify : false
contact :
default_expiration : 3600
mailboxes : 20001@default
max_contacts : 5
maximum_expiration : 7200
minimum_expiration : 60
outbound_proxy :
qualify_frequency : 60
qualify_timeout : 3.000000
remove_existing : true
remove_unavailable : false
support_path : false
voicemail_extension :

I assume this means authentication failed? The tech from Sangoma didn’t mention it. I’ve been waiting on him for over a week. He pretty much said it works on his end. Now if there are more important companies than me that need attention, I completely get that. This is a masochistic hobby of mine and I would like to learn more of what the heck I’m doing. If he thinks It’s my network, wouldn’t the phones work plugged directly into the ISP modem?

Not enough information here to give you a definitive answer, but I can get you pointed in the correct direction.

Since you used the terms EPM and Endpoint Manager I am assuming you are using FreePBX or PBXAct.

  1. Which PBX and what version?
  2. Is the PBX hosted on your LAN or externally?
  3. Is the Sangoma phone on the same LAN as the PBX or on an external network?
  4. What is the firewall/router that the PBX is behind? A description of your ingress and egress rules for bonus points.
  5. What is the firewall/router that the Sangoma phone is behind?
  6. What or where is the provisioning server and what protocol (tftp or http)? (the URL where the provisioning files will be found)
  7. How is the Sangoma phone getting this provisioning server set in each phone? (manually via connection to the phone, setup in the Sangoma Portal with a provisioning redirect)
  8. If using the Sangoma Portal to redirect to your PBX’s provisioning URL, then you can see the actual polling date/time at:

In the file /var/log/messages on the provisioning server will be the log entries to show the attempts to provision and their result via your defined protocol. I use ‘tftp’ and can view the provisioning attempts with the following command from a command line: tail -f /var/log/messages|grep in.tftpd

If any of these questions or their answers are not familiar to you, then it is likely that you have not properly setup your provisioning environment completely.


FreePBX & our server is plugged directly into a passthrough ISP modem using only FreePBX’s firewall. None o the phones are on the same network and we have tried connecting them directly to the modem and behind our router. Some of the phones use TFTP and some use HTTP. The other phones get their provision from End Point Manager on our server and I think the Sangoma S705’s connect both to Sangoma and to our server like the other phones.

As far as the log, it shows the first page and I don’t know how to navigate this log or get back to the original cli spot where I can do commands. Google isn’t any help on explaining the very basics of navigating inside the cli.

Ctrl-C will end the ‘tail -f’ command.

Do the external phones connect (or intend to connect) to the FreePBX via the public internet or via a VPN?
If via VPN; is it your own VPN or the FreePBX VPN?

With phones on a different network than the FreePBX server there is a bit of network configuration that has to be in place to allow the phones to see the provisioning server. Also there will be security concerns depending on your chosen provisioning protocol. TFTP by definition does not have a authentication mechanism. HTTP or HTTPS requires authentication.

You need to be familiar with your network setup and how to adjust it to proceed. You may benefit from some network or FreePBX consulting work. I am not that person.


Check EPM > Extension Mapping and take the phones off VPN if that’s how they are currently set, whitelist the IP addresses they’re coming in from, for S-Series factory reset with *** and hold X for 15 seconds. After few minutes, check the Sangoma Portal to see if they are at least reaching the redirection server — If not, it’s a local network issue.

By complete chance I added all our static IP addresses to the firewall and not just the whitelist we already had them listed in. This resolved the issue and everything works now.

Also thanks for the help. I was just planning on learning something during this process, but I’ll at least make a note in my phone server notes that I need to add Trusted Statics to the firewall and not just whitelist them.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.