How to uninstall, so I can try to install clean, again?

Hi Folks,

Having installed asterisk/freepbx on Ubuntu 7.10 several times, I can’t quite say I’ve got the process down smoooothly yet.

Of course I wish I had resources to properly backup/revert (here at my parents, where I’m on ‘vacation’ setting them up with VOIP-deluxe), but I didn’t carry a spare external disk etc.

I’m regretting this now, of course.

Anyway, what went wrong this time, is I went against the defaults (doh!) and tried to install into /var/www, and not /var/www/html as suggested by the defaults, and which has worked out so well for me previously at other places.

The problem is that when I try to do things over again, the installer no longer prompts me, or gives me the option to correct my previous errors (and simply use the defaults this time; /var/www/html).

How can I clean out previous install files (where are they?); I only know to clean out what was placed into /var/www but this isn’t helping me install things differently on subsequent attempts?

Thank you folks very much in advance,

  1. blow away the untarred freepbx directory that you’re installing from and untar the tarball again. If you don’t have the tarball, download it again.

  2. if you’re really starting from scratch, you can drop the freepbx related databases. If you need help doing this, ask.

I don’t know this about FreePBX for sure, but usually cached installation information is kept in the installer directory, if it’s kept at all. There’s no “registry” or anything in Linux, but there’s a small possibility that some stuff is kept in a dotfile in root’s home directory. Probably not, though.

Thank you very very much for your reply, which narrowed down & confirmed several things for me, and motivated me much further.

The suggestions you made were all good, and I tried them all without success however.

What eventually worked for me was locating and deleting the following file: /etc/amportal.conf …which seemed to hold all the initial settings from the first install. Afterwards I was able to change installation values.

Thank you again, now I can finally sleep. Aaaaahhhh.