FreePBX | Register | Issues | Wiki | Portal | Support

How to turn on DAHDi ports

dahdi
Tags: #<Tag:0x00007fafc2d307d8>

(Eyzi) #1

Hi, I’m having problems getting 48-ports of FXO to work on FreePBX. I have 2xA400 cards installed and I can see all 48 ports in DAHDi config page, but only 24 of those are working. Upon troubleshooting this, I ran ‘lsdahdi’ and saw that ports 25 to 48 does not have the (In use) label which I think might be what’s happening.

I tried to search how to turn these ports on or off but no luck. I’m hoping someone here could help me with this. Basically, I’m just trying to make ports 25 to 48 show the ‘In use’ label to see if that solves the problem.


#2

Probably your DAHDI configuration is incomplete. Have you ever been able to use the 48 ports? Or did you first have 24 ports and later you added the other 24 ?


(Eyzi) #3

I was never able to use all 48 ports. I ran into a lot of interrupt errors before which now seems fixed. I can run each card individually without a problem. But never all 48 at once, and that’s what I’m required to build.

By DAHDi configuration, you mean I just need to run dahdi_cfg again, right?

Thanks


#4

You didn’t say you have interrupt issues. Having interrupt issues means your motherboard can’'t handle both cards at the same time. Sorry, but if moving the cards to other slot doesn’t fix it, there is not much left to do.


(Eyzi) #5

Hmm. Well, I thought I’ve fixed it and it’s just a matter of turning those ports on in the config, because the boards themselves seem to be on at the same time. I’ll keep looking. Thanks.

Would you know what motherboard spec I should look for to figure out which ones can handle two A400 cards? Or perhaps a specific model that can?


#6

Not sure which particular model would support that, but it must be a motherboard capable of withstanding a high amount of interrupts. Have you tried moving the cards to other slots?


(Dave Burgess) #7

Setting up DAHDI is Never “just need to run dahdi_cfg”. DAHDI is a pain in the ashes to set up, even when you’re doing something relatively simple (which you are not).

Important note - DAHDI is not technically part of FreePBX, even though there is a DAHDI control module built in to FreePBX. Since this is an atypical installation, you are probably going to need to do it the old fashioned way.

You will need to start with running dahdi_cfg. When you get done with that, you may also need to edit the output files from that program.

In your examples, all of the ports are “RED”, which means that the Dahdi part of the config is broken in one way or another. Many times, this indicates that the T1/E1/PRI isn’t plugged in or some other, similar problem.

Also note that any problem with the config (wrong echo correct, for example) can cause the ports to just semi-silently fail.

While DAHDI might seem like it should “just work”, I’ve found it to be a particular and petulant system that reacts badly at the least provocation.

@arielgrin does have a good point - the card may not be able to operate with a twin in the machine. I’d suggest reaching out to Sangoma directly (since, like I said, this isn’t actually a FreePBX problem) and see if they can give you a little more direction on things that might be going wrong.

One final note - there are literally hundreds of tutorials around (including ones in the FreePBX Wiki) on setting up and troubleshooting DAHDI.