FreePBX | Register | Issues | Wiki | Portal | Support

How to route all calls through 1 nic e.g eth1


(Arsalan) #1

hello, I got freepbx 13.0.192.16-1.shmz65.1.57 and with 2 nic configured on eth0 and eth3 but for some reason freepbx is using eth3 for outgoing calls and if it got disconnected from eth3 trunk stops working …so what I need is if some one can help me and let me know how to configure it on another nic or reroute all calls on eth0 if eth3 fails or if I can configure it on eth2 for external dialing.


#2

Do you need failover functionality or just direct all calls through eth0 all the time regardless of the state of eth3?


(Arsalan) #3

Thanks for reply ,I need all calls through eth3.


#4

You have two options. Either you set eth3 as your default gateway or you create a static route on eth3 for your provider’s IP.


(Arsalan) #5

and how can i do that ??


#6

If you want to set eth3 as your default gateway, you can do that from Sysadmin module, on network configuration. If you want to create a static route, you need to manually create a file on /etc/sysconfig/network-scripts called route-eth3.cfg and type the static route on it, according to the correct format for CentOS.


(Arsalan) #7

I just checked System Admin module but didn’t find any settings regarding this .can you elaborate please.
i got both eth0 and eth3 set as static ip .


#8

You need to go to network settings, then select your network card and fill the gateway field.


(Arsalan) #9

so if i remove gateway from eth3 will all calls go through eth eth0?? i got both with gateways filled .


#10

You need to decide which network card you want to be your default gateway fill the gateway field and delete the gateway on the other card.


(Arsalan) #11

Thank you , my problem is solved .


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.