How to make ring tone on transferred calls use Internal Alert Info?

I found a couple of old threads about this and didn’t see much resolution. Is there a way to do this without changing extensions.conf, and if not how do I do it?

The situation is that the user wants calls being transferred to them to be treated like an extension to extension call.

In a call that’s been transferred it looks like it’s not using the alert info

pbx.c: Executing [[email protected]:35] ExecIf(“SIP/VI-outbound 1-00012833”, "0?Set(ALERT_INFO=") in new stack

while in a direct extension to extension call it does

pbx.c: Executing [[email protected]:35] ExecIf(“SIP/2012-00012845”, "1?Set(ALERT_INFO=") in new stack

Any help would be appreciated.

PBX Version:
PBX Distro: 12.7.8-2104-1.sng7
Asterisk Version: 16.13.0

Any ideas?

When you press the Transfer key on an IP phone, it puts the remote party on hold and starts a new call. Asterisk doesn’t even know it’s a transfer so the ringtone will be the same as for a normal internal call.

I’m guessing that you are either using DTMF codes such as *2 or ## (if so, why?) or doing a blind transfer (if so, why?)

Maybe these settings in advanced-settings will help…


Attended transfer, using the transfer key on the phone which does ##.

I understand that if the phone rings right after getting an internal call informing there is a call for them that it SHOULD be obvious but they complained,

Your user name is appropriate here… Thanks. Will try it now.

switch them to your internal alert info…

EDIT: It’s my standard user name in several (non-technical) forums… :wink:

EDIT2: I use these settings with D65 phones and all transferred calls ring the internal ring tone. It might depend on your phone model.

Thank you for the help. We got just the effect we were looking for. I’m happy you helped us before we started hunting for an overcomplicated solution.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.