How to limit inbound calls per extension? Queue extensions receive two calls at once

Asterisk 11 and 13 - same problem.

Queue config:

[600] announce-frequency=0 announce-holdtime=no announce-position=no autofill=yes autopause=all autopausebusy=yes autopausedelay=0 autopauseunavail=yes joinempty=yes leavewhenempty=no maxlen=0 memberdelay=0 min-announce-frequency=15 musicclass=Custom penaltymemberslimit=0 periodic-announce-frequency=0 queue-callswaiting=silence/1 queue-thereare=silence/1 queue-youarenext=silence/1 reportholdtime=no retry=5 ringinuse=no servicelevel=60 setinterfacevar=yes strategy=random timeout=30 timeoutpriority=conf timeoutrestart=yes weight=0 wrapuptime=10 eventmemberstatus=no context= member=Local/[email protected]/n,0,"Oper. 402",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 403",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 404",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 405",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 406",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 407",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 408",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 409",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 410",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 411",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 412",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 413",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 414",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 415",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 416",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 417",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 418",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 419",hint:[email protected] member=Local/[email protected]/n,0,"Oper. 420",hint:[email protected]

I have a bug in Queues. When an extension use *46 to unpause itself, the queue sometimes send 2 calls on 2 lines on a extensions. Operator answer to first call, and second call then have timeout and leaves to other operator. This is resulting in a NO ANSWER in CDR reports, which is bad.

Since the call-limit=n is deprecated, how can i limit inbound calls per extension?

`freepbx1*CLI> sip show inuse

  • Peer name In use Limit
    401 0/0/0 2147483647
    402 0/0/0 2147483647
    403 0/0/0 2147483647
    404 0/0/0 2147483647
    `
    How to make limit = 1?

For your queue, what do you have ‘Skip Busy Agents’ set to?

Try Skip Busy Agents Yes or Yes+(ringinuse=no) (read description of that settings) in Queue settings. That will make the agent not recieve a 2nd call at all if he is busy and can not answer the call.

From the description:

When set to ‘Yes’ agents who are on an occupied phone will be skipped as if the line were returning busy. This means that Call Waiting or multi-line phones will not be presented with the call and in the various hunt style ring strategies, the next agent will be attempted.

Skip Busy Agents was already set to “Yes+(ringinuse=no)”.

The second call arrives not when operator already talk, but when it is going unpaused. This happens not every time, most of time the queue is forwarding one call per extension but sometimes it pushes two calls…

i would add skip busy agents to yes in the gui - this sets ringinuse to yes

It is already set to Yes+

This is a bug in asterisk 13.9 and it is fixed in 13.10.
Please update your system.

OK, i will try, thank you.

Seems like the problem is gone. Thank you @psdk.

SOLVED.