FreePBX | Register | Issues | Wiki | Portal | Support

How-To Guide for Google Voice with Freepbx 14 & asterisk gvsip, Ubuntu 18.04

asterisk
pjsip
freepbx
Tags: #<Tag:0x00007fdfa1650ff8> #<Tag:0x00007fdfa1650d78> #<Tag:0x00007fdfa1650b70>

(Chris162) #448

This is a fresh install and I followed the guide line by line:

I figured a way to monitor pjproject, seems there is a problem with TLS:
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: sip_resolve.c DNS AAAA record resolution failed: No answer record in the DNS response (PJLIB_UTIL_EDNSNOANSWERR EC)
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: tlsc0x7f0e08004238 TLS client transport created
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: tlsc0x7f0e08004238 TLS transport 103.144.455.xx:47675 is connecting to obihai.telephony.goog:5061…
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c Received 55 bytes DNS response from 8.8.8.8:53
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c Nameserver 8.8.8.8:53 state changed Probing --> Active
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c DNS response from 8.8.8.8:53 id=1 discarded
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c Received 99 bytes DNS response from 8.8.8.8:53
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c Nameserver 8.8.8.8:53 state changed Active --> Active
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: resolver.c DNS response from 8.8.8.8:53 id=2 discarded
[2018-08-09 19:48:10] DEBUG[10216]: pjproject:0 <?>: tlsc0x7f0e08004238 TLS transport 103.144.455.xx:47675 is connected to obihai.telephony.goog:5061
[2018-08-09 19:48:20] WARNING[10216]: pjproject:0 <?>: SSL 6 [SSL_ERROR_ZERO_RETURN] (Read) ret: 0 len: 32000
[2018-08-09 19:48:20] DEBUG[10216]: pjproject:0 <?>: tlsc0x7f0e08004238 TLS connection closed
[2018-08-09 19:48:20] DEBUG[10216]: pjproject:0 <?>: sip_transport.c Transport tlsc0x7f0e08004238 shutting down, force=0
[2018-08-09 19:48:20] DEBUG[10216]: pjproject:0 <?>: tsx0x7f0df40284b8 State changed from Calling to Terminated, event=TRANSPORT_ERROR
[2018-08-09 19:48:20] DEBUG[10216]: pjproject:0 <?>: dlg0x7f0df00057c8 Transaction tsx0x7f0df40284b8 state changed to Terminated
== Everyone is busy/congested at this time (1:0/1/0)


#449

Its been a couple days since I installed a test setup, maybe something changed.

I will spin up an install tonight to make sure everything still works as far as the guide goes.

If run into a problem as well, or the same problem as you, then I can be more hands on about how to fix it.

If I do not run into any issues with my install, then I can try helping you further with what might be going on, at the moment my first thought was that you had more than one TLS transport configured, but maybe not.


(Chris162) #450

Ok and thanks for your help


#451

I helped a friend do an install on a remote server, it worked perfectly. (prior to updating the guide)

Afterwards I finished updating the guide so that all of the sample files are no longer copied, now only a couple are used. (this install is working for me currently)


(Koanga) #452

All good after following the guide provided but noticed 2 issues:

  1. CDR not working - tried to figure it out why but no luck

  2. After system reboot UPC node not running, this is a fix by removing the UPC and install it again, but every system reboot, the same error.


#453

Thank you for the report koanga, I am going to try and reproduce it on my end. (The UPC)

My CDR and CEL are both working perfectly.

For your CDR did you install that part of the guide, I listed it as optional and had it hidden in a summary button that you have to click on “summary” to expand that part of the guide.


(Koanga) #454

I did follow the tutorial and inatall the “optional” for the CDR.


#455

@koanga “UCP node” is referring to what I believe is the part of UCP that allows you to get commercial modules for UCP, or something to that affect, I could be wrong about this.

My dashboard shows the same “UCP Node is not running” message, but my UCP module is still functioning. I assumed this was just normal behavior for an OpenSource install, but maybe @tm1000 can confirm if that message should be showing on the dashboard or not.


(Tom Ray) #456

The UCP Node is a backend process that handles real-time updates to the UCP for FreePBX. It requires NodeJS and Process Manager to be installed. As well the UCP Node Server, while free, is listed as a Commercial Module. That means the system must have System Admin installed and be Activated. None of which can be done in non-Distro setups.

So you can still have the UCP but you will not be able to get the new features/functions that v14 and future versions will have access to via the Distro.


#457

Excelllent, thanks for the information @BlazeStudios I was thinking it was something along those lines, appreciate it.


(Andrew Nagy) #458

No. This is not correct. “UCP Node Server” used to be a separate module that was commercially licensed but did not require sysadmin nor did it even require the distro or cent os. In FreePBX 14 UCP node is included with UCP and the separate module doesn’t exist in 14.

The license is also AGLP3. So UCP node is the same license since its part of UCP.

I don’t know what this implies but it’s also wrong.

While I like BladeStudios, and I know he is just misinformed, please take note that he does not work for Sangoma. Any official comment about how any modules work should come from a Sangoma representative. We all have little blue Sangoma symbols in the lower right hand side of our avatars.

image

The UCP Node Server component, which is part of UCP, and is open source. (see links above). Allows such things as users being able to connect to XMPP over UCP. XMPP is also open source (formerly commercial).


(Tom Ray) #459

I didn’t catch that they were merged together in v14. So then that does make a difference. Still doesn’t change that NodeJS and the Process Management module is needed for it.

I guess this goes back to the whole “Manual Install” issue I spoke about earlier. The issues in those cases aren’t about the fork of Asterisk or the changes for GVSIP, it’s about not understanding how to fully deal with a manual install and what backend pieces are really missing and need to be installed.

It’s a bit unfair to the OP and those who made this guide to have to answer every little “I followed your guide but…” issue when none of them actually have to do with the part the OP wrote up but just manual install woes in general.


#460

apt-get install nodejs on debian will likely get you

v0.10.29

You might well want at least v8 (you don’t have to eat any veggies though :slight_smile: )

A good source I use is:-

https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions

which should get you squared away with both node(js) and npm for your js stuff.

No more woe, from that point on you can use npm itself to manage the sub-system.


(Andrew Nagy) #461

Have you even glanced at the wiki for installing 14?

https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Debian+8.8#InstallingFreePBX14onDebian8.8-Installnodejs

^ The section about installing NodeJS. Been there since day one.

Manual install “woes” are the result of people not following instructions. The instructions are on the wiki. The wiki can be edited by outside people if you want it updated to something newer than Debian 8.8.

The “OP” asked about UCP Node. You stated wrong information about it. I merely corrected that information. Not sure why we have to go down the road of how ‘unfair’ FreePBX is… geesh


(Andrew Nagy) #462

Same problem with CentOS. So we just use nodesource. :smiley:


#463

This is what they were talking about, If you reinstall UCP, then it works until your next reboot, at which point you see this:

node --version
v8.11.3

I am going to tinker to see if I can solve this riddle, anyone have any clues for as to what I should check?
I already tried sudo fwconsole start ucpnode to no avail.

ps aux | grep node

shows nothing running.

personally the options present in the default UCP are all that I need myself, but some users may be looking to download the extra goodies and what not, also if you are unfamiliar and see the red fire icon on your dashboard, that is bound to worry some people that don’t realize UCP will still work regardless.


(Tom Ray) #464

Yes, I did state wrong information and I was corrected. Not an issue, I’m cool with that.

I never said FreePBX or Sangoma was unfair, I said it was unfair to THE OP who WROTE the guide for using GVSIP has to answer questions about manual installs when people have not read the Wiki guides on said manual installs. I was expressing empathy/sympathy for xekon having to deal with issues that are not related to his guide, that’s all.


(Andrew Nagy) #465

then you aren’t starting your system with fwconsole start

https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Debian+8.8#InstallingFreePBX14onDebian8.8-AutomaticStartup

https://wiki.freepbx.org/display/HTGS/Example+systemd+startup+script+for+FreePBX


#466

I would suggest to anyone who has followed this thread, that if you want no pain, . . .

A) install FreePBX on any OS of choice , using the WIKI recipes if the ‘distro’ is not feasilble.

B) When it is working, which is hard to dispute, then . . .

C) you can then rebuild asterisk with any ‘patched’ version that works given all the source and tools are in place, it just works that way and has for years.

Putting the cart before the horse has never worked well and always causes these muddleminded (albeit brave) disconnects from the obvious route.

JM2CWAE


(Jimbolaya) #467

Thank you very much for this guide.

One thing I haven’t gotten to work and I see no discussion on this is setting this up for receiving faxes. I’m having an issue that I don’t really know if it’s a general issue or if it’s related to the routing set up for gvsip.

I installed “fax” module. I set up an IAX2 fax extension.

In “Inbound Routes”, under my route, in the “Fax” tab, I set “Detect Faxes” to Yes, “Fax Detection Type” to SIP and set the “Fax Destination” to my fax extension.

In IAX2 extension I permit 127.0.0.1/255.255.255.255 and set requirecalltoken to no. I notice when the call from the fax machine comes in, I have the following error.

[2018-08-13 13:52:09] NOTICE[1496][C-00000001] res_fax.c: FAX CNG detected but no fax extension in context (from-did-direct)

It seems to me that this means the fax is being detected, but isn’t finding an extension to go to. One thread I saw mentioned that this message means that the fax detection (4 seconds) is too short.

If anyone has a suggestion for a fix or if there’s something obvious that I seem to be missing, please let me know. If there’s a better place to look, that would be fine too.