Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

How-To Guide for Google Voice with Freepbx 14 & asterisk gvsip, Ubuntu 18.04

Tags: #<Tag:0x00007fdf9a3c9ac0> #<Tag:0x00007fdf9a3c9958> #<Tag:0x00007fdf9a3c9728>


Actually you can as you previously noticed, put your imprimatur on both ASTERISKVERSION and more subtlety ASTERISKVERSIONNUM, Naf has yet to to that, probably he should :wink:


Your trunk config is right. Hover over the (?) to see where $OUTNUM$ comes from. It’s just a placeholder FreePBX uses where it substitutes the number to be sent out to the trunk.

Outbound route is fine.

Transports are fine.

Remove the global section from the custom file… you don’t need it.

No application ‘Macro’ ? Guess you didn’t build it. (in make menuselect it’s under Applications - Deprecated)

It worked before because you were bypassing FreePBX dialplan.

in your custom file change context=from-external in the type=endpoint section to context=from-pstn which aligns with FreePBX inbound dialplan.


I just installed from fresh again using the updated guide I am making.
During that process I removed the make samples line.
removing make samples seems to have made a few things have errors after a freepbx install.
Errors that I did not previously have.

So far this is what I have had to do to resolve those errors after the freepbx install:

Dashboard error that broke retrieve_conf said sipsettings was not installed.

sudo fwconsole ma install sipsettings

Dashboard error: Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly.

go into module admin > select conferences and select uninstall. After it uninstalls, go back in and reinstall it, clear the error from the dashboard then reboot.

with the make samples being ran one time on initial install in my old method everything on the dashboard had green check marks,
without make samples, after the install on dashboard you will see “Mail Queue” with red flame and an error message on mouse hover:
Unknown output from mailq: [[“MSP Queue status…”,“VvarVspoolVmqueue-client is empty”,"\t\tTotal requests: 0",“MTA Queue status…”,“VvarVspoolVmqueue-client is empty”,"\t\tTotal requests: 0"],0]

So far thats three errors, that I dont remember seeing when running make samples on my original guide.
I completely believe you when you say it has caused issues in the past, maybe that has since been resolved?
I really do want to make a guide that is the “correct” way of doing things, but I also need for everything to work.

Maybe it’s that when I removed the make samples line that there were some other steps I should be doing to make up for that?

I do not know why using the make samples command would prevent the errors, but it certainly seems to.

Any advice appreciated, For the moment I am going to start over and put make samples back in so I can see if the other parts of the guide are working as expected.

Thanks :slight_smile:

(Andrew Nagy) #31

None of your errors have anything to do with making samples since freepbx doesn’t read sample files.

In fact making samples does exactly that. It makes sample configurations with extra data to demo a PBX. Unless you know what make samples does you could be exposing your pbx to be compromised.

If you want to make a complete guide there are several on our own wiki. None of which use make samples. You probably should base your work off of thos. But do whatever works best for you. as for freepbx, officially we do not support make samples and advise strongly against it. Nothing has changed in this regard.

Source: I manage and run the freepbx team.


This from the horses mouth as to way it is not a good idea for most people to

make samples


@tm1000 without make samples the /etc/asterisk dir is empty on a fresh build. Thus the step where you start asterisk with ./start_asterisk start before running the installer will fail. How does this work without at least /etc/asterisk/asterisk.conf in place?

(Andrew Nagy) #36

As mentioned previously we have many manual installation guides on our wiki. None of them use make samples. They all work. This is also the same process for the freepbx RPM in our distro

We never run make samples. “start_asterisk start” doesnt fail.


ubuntu IS debian, in the same way as SNG7 IS redhat.


Yes I understood that, I just wasnt sure if running the file would treat it as such. I could give it a go and see though :slight_smile:


billsimon, do you know how I would re-add the debug=true that was in the global section? so that I can help with the debugging in Naf’s thread.


The pjsip_custom_post.conf is included right after the [global] section of pjsip.conf - so you can put “debug=true” as the first line of pjsip_custom_post.conf, before any section in [brackets]


If you use systemd (or sysV) to start asterisk you might need to edit (in debian) /etc/default/asterisk to ensure that the user and group that starts asterisk is asterisk, if you start as root, FreePBX can’t see it, the fwconsole script ends up restarting asterisk with -U asterisk -G asterisk


Just FYI, naf just posted this a little while ago…

we got any freepbx folks here? i think we might need their help on a couple of things…

If you feel like helping head over to


He just posted a followup as I was typing…

just a general call to see if we can get a volunteer to add the new auth type and a couple of those miscellaneous settings to the pretty gui…

Maybe something tm1000 might like to do?

(Andrew Nagy) #49

I’m on vacation this week but next week I’ll get this done in the Google voice module in my spare time for the community.

(Andrew Nagy) #50

I replied to the dsl reports thread

(Shawn Lockner) #52

to start with… i am trying to install with centos7… so i know its not the dist your using…

for some reason i cant seem to get PJsip to install… i have used modified version of your intrustctions and i have used the intructions just to install centos 7 freepbx 14 with no pathc. when ever i log in to asterisk and try a command like pjsip show endpoints it says no such command… however when i run the same command in my production freepbx the commands seem to work.


Chech that the pjsip modules are not ‘noload’ in


(Andrew Nagy) #54

I’ve never encountered someone having so many issues with not running make samples.

The distro, which is installed hundreds of times a day, uses the same methodology to install freepbx as is in the wiki. We never run make samples and we never add asterisk.conf. We never have as many issues as you are having.

Again. As Dicko pointed out. When you run make samples you expose your system. Even the asterisk wiki says this.


I can endorse @tm1000 's last post, personally I have been installing asterisk from source for various platforms for many (many) years and literally hundreds of time.

I discovered very early on that “make samples” NEVER was useful, all the files as asterisk puts it “for reference” are in


is a working PBX

If you really MUST run make samples, I would caution you to look in the Makefile and hold very close to your head the ominous:-

# Overwite config files on "make samples" or other config installation targets