FreePBX | Register | Issues | Wiki | Portal | Support

How-To Guide for Google Voice with Freepbx 14 & asterisk gvsip, Ubuntu 18.04

asterisk
pjsip
freepbx
Tags: #<Tag:0x00007fdf98c2a4c8> #<Tag:0x00007fdf98c2a388> #<Tag:0x00007fdf98c2a220>

(Dev Null) #377

Nope, those aren’t enabled by default.


(Assembler) #378

That download problem resolved itself today when I tried it. So it’s up and running and registering with GV. Now I just need to figure out how to configure my Obi100 to talk to asterisk. Any clues? It’s all new to me.


(Jimbolaya) #379

I found the wiki entry on this to be pretty good:

https://wiki.freepbx.org/pages/viewpage.action?pageId=4161592


(Rob Thomas) #381

As all the documentation says - DO NOT USE SUDO. Run everything as root. Using sudo causes problems.


(Jimbolaya) #382

Ah, sorry. I missed that. Personally, being fairly comfortable messing around, I just ran everything as root anyway.


#383

Yes, that is the intent, I implemented your suggestion and the settings stick. Thank you.


#384

I’ve configured things the way it says in the guide and I get the following errors when asterisk is reloaded:

[2018-08-04 02:14:14] WARNING[20712]: res_pjsip/config_auth.c:60 auth_type_handler: Unknown authentication storage type ‘oauth’ specified for auth_type
[2018-08-04 02:14:14] ERROR[20712]: config_options.c:794 aco_process_var: Error parsing auth_type=oauth at line 23 of /etc/asterisk/pjsip_custom_post.conf
[2018-08-04 02:14:14] ERROR[20712]: res_sorcery_config.c:336 sorcery_config_internal_load: Could not create an object of type ‘auth’ with id ‘gvsip1’ from configuration file ‘pjsip.conf’
[2018-08-04 02:14:14] ERROR[20712]: res_pjsip_config_wizard.c:1087 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’
[2018-08-04 02:14:14] ERROR[20712]: res_pjsip_config_wizard.c:1087 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’
[2018-08-04 02:14:14] ERROR[20712]: config_options.c:776 aco_process_var: Could not find option suitable for category ‘gvsip1’ named ‘outbound_registration’ at line 47 of /etc/asterisk/pjsip_custom_post.conf
[2018-08-04 02:14:14] ERROR[20712]: res_sorcery_config.c:336 sorcery_config_internal_load: Could not create an object of type ‘endpoint’ with id ‘gvsip1’ from configuration file ‘pjsip.conf’
[2018-08-04 02:14:14] ERROR[20712]: res_pjsip_config_wizard.c:1087 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’
[2018-08-04 02:14:14] ERROR[20712]: res_pjsip_config_wizard.c:1087 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’
[2018-08-04 02:14:14] NOTICE[20712]: sorcery.c:1285 sorcery_object_load: Type ‘system’ is not reloadable, maintaining previous values
[2018-08-04 02:14:14] ERROR[20712]: config_options.c:776 aco_process_var: Could not find option suitable for category ‘gvsip1’ named ‘support_outbound’ at line 14 of /etc/asterisk/pjsip_custom_post.conf
[2018-08-04 02:14:14] ERROR[20712]: res_sorcery_config.c:336 sorcery_config_internal_load: Could not create an object of type ‘registration’ with id ‘gvsip1’ from configuration file ‘pjsip.conf’
[2018-08-04 02:14:14] ERROR[20712]: res_pjsip_config_wizard.c:1087 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’

Do you have any suggested debug command to verify if gvsip trunk is communicating properly?

Thank you,


#385

That line above make it sounds like oauth is not even present, which means you either don’t have Naf’s version of asterisk, or there was a problem when you built it. This is my best guess based on the above error messages.

oauth is required for gvsip to work, and you would have it if you had a functioning copy of Naf’s asterisk/patch

Are you following this guide line for line? or trying to apply it to some other install type?


#386

You’re right. I have original FreePBX distro. Is there anything required? or can I recompile it or something?


#387

@schalykh It is possible, one of @billsimon early post sum it up better than I can, because I have not tried anything but the Ubuntu install:


#388

Don’t use custom built Asterisk with FreePBX distro. Either use distro or roll your own all from source. Mixing them will bring trouble. I only did it to experiment.


#390

@billsimon Having blatantly ignored that advice over many years with no downside, I would respectfully disagree. there a couple of patches that Sangoma provide against Asterisk, that would not be applied of course, conversely you can add any other patches against Asterisk to your hearts content, be that Cisco stuff or the new but unfinished NAF stuff, other than the absence of the Sangoma patches, what trouble have you experienced to warrant that statement ?

Caveate, I have only a few deployments that insist on the “Distro”, but each and every one is absolutely happy with my ‘version’ of asterisk and have been for a long time.


(GPz1100) #391

@xekon

Both problems resolved; 1) dropped calls when calling from gvsip to gv numbers that go unanswered, and dropped calls when calling your own gv #.

Solution: https://www.dslreports.com/forum/r32067996-GVSIP-Asterisk-Freepbx-503-error-on-voice-mail-handoff

Specifically, https://www.dslreports.com/forum/r32068021- for #1, and https://www.dslreports.com/forum/r32068277- for #2.

#1 Was really my own doing as it was a force of habit to add the ‘r’ to the dial option. You may want to make a note above NOT to include it.

#2 Was from the instructions in the OP in this thread.


#392

The trouble is that when you go off the path you then have to maintain asterisk yourself and not receive the benefit of the Sangoma testing and package release process. Not sure why I’d install the distro and not reap its benefits.


#393

This thread is surely about adding function to asterisk that Sangoma as yet does not support.

That one can benefit from both Sangoma’s value added stuff and also NAF’s without serious ‘trouble’ has yet to proven false.

Personally I doubt that there is any ‘burgeoning trouble’ by doing that, and my personal ‘quick tests’ suggest that there is in fact no conflict of co-existance, personally I have no need for GV, it is just a “Gedankenerfahrung” that any tinkerer worth his salt should not be discouraged from doing , with 5 dollar a month or less VM’s out there, just suck it and see if GV floats your boat :slight_smile:

Such a person would have most of the best of both worlds, and hopefully broadened her knowledge.

JM2CWAE


#394

Thanks, after dinner I am going to check this out if I have time. If not then I will check it out in the morning, appreciate the information!


#396

@schalykh your asterisk is still reporting as version Master, which means you must have skipped this line, or been in the wrong directory when you ran it.

sed -i 's/^MAINLINE_BRANCH=master/MAINLINE_BRANCH=15/' build_tools/make_version

Seems something has changed in Naf’s repository and that line no longer changes the branch number, I am investigating now.

EDIT: I believe this should fix the version error:

sed -i 's/MAINLINE_BRANCH=.*/MAINLINE_BRANCH=15/' build_tools/make_version

I am testing it now, will edit this post after I have tested it.

Edited by xrobau: Removed sudo.


(Rob Thomas) #397

As I keep saying, do not use sudo. Start with ‘sudo -i’ and then run everything as root.

Because step one is ‘sudo -i’ and run everything as root.


#398

I think their primary issues with installing was because the build file changed and so my instructions needed updating:

I just tested my change and it fixes the version problem.

Also the step where they said sudo was missing, would not have been a problem, because they should have been in their home folder(at the wget step), I suspect they skipped the reboot commands, or decided to change directory back to /usr/src/asterisk, instead of simply following the guide line for line.

I do not use root, I used sudo, and have followed this guide countless times with clean install :slight_smile:


#399

Do I need to do it again from scratch? ie reinstalling ubuntu and follow the guide?
I’ve not used root. always used sudo.