How to get a PSTN dialtone?

AsteriskNOW 2.0.2 / Asterisk 1.8.15

System is set up to require dialing 98 to make an outside call, e.g. 98-555-6789 or 98-1-234-555-6789.

FreePBX Outbound Route rules that support this are:

(prefix) 98 (match pattern) NXXXXXX
(prefix) 98 (match pattern) 1NXXNXXXXXX

I would like to be able to just dial 98, nothing else, and get a PSTN dial tone from which I can dial anything I want.

I tried an Outbound Route rule with just a prefix of 98 and no match pattern, and when I tried it I got “All circuits are busy”. (I can see that they are not.)

What is the correct dial rule pattern to get a PSTN dialtone in this manner?

I’m aware of the security implications and this is for special configuration purposes only, then it will get turned off.



What type of trunk are you trying to do this with? I have done this with DAHDI trunks using the rule you stated, prefix=98 and all other fields blank. I doubt it will work with non-analog trunks.

I’m using SIP trunks to Grandstream FXO gateways to the PSTN.

If what I tried can’t work, is there another way?

As Ned Flanders would say, “That’s a noodle scratcher.” The only thing that comes to mind is if the ATA has a built in feature to allow it. /shrug

Perhaps you could experiment with the dialplan on the ATA and strip the prefix there instead of with the dial rules in FreePBX.

You can’t pull a dial tone from a SIP trunk because there is no dial tone on a sip trunk. It’s all data. The “dial tone” you hear isn’t coming from Asterisk, it’s being generated in the phone (or ATA).


It’s SIP to the Grandstream FXO gateway and from there it’s regular analog PSTN. When the FXO gateway takes the line off-hook, presumably a dial tone is generated on the PSTN line. I’d just like to be able to hear that dial tone, which is just audio like any other audio (e.g. voice).

Is the grandstream set to 1 stage dialing or 2? If 1, then its waiting for a dial string before it goes offhook I believe. If 2, then you get a dialtone you can hear, and have to dial out across it. All depends on if you set it up as a true FXO trunk, or an extension bridge I guess.

It’s set for 1. I’ll try 2-stage and report back. Thanks…