How to force failover


(United Kingdom) #1

I have two freepbx installations, one as a DR failover for the primary… When it comes to updating the secondary there’s zero problems, as it’s normally passive anyway, it’s just a case of updating. However, I cannot seem to successfully block the channel to the primary, while keeping it connected to the Internet to be able to update it. Sure, I can take it off the network completely, but then I can’t update it!.
I’ve tried blocking channels in the firewall, but it still seems to respond to 5060 UDP. How can I take down the service so that the supplier will failover to the secondary, while keeping the access to the Internet for updates? How do other people do this?
TIA, Steve


(Lorne Gaetz) #2
fwconsole stop

will stop Asterisk and all other call services.


(Tom Ray) #3

Or just disable the trunks. Then they are down and you can update without complaints of not being able to connect to asterisk. Plus updates could restart the services before you really complete them.


(Lorne Gaetz) #4

Not 100% sure but disabling trunks may just disable registration, which is prob not in play with failover described.

edit - Tom is correct, disabling a trunk removes both the registration and the peer for both chan_sip and pjsip. At one point that wasn’t the case for pjsip.


(Tom Ray) #5

Disabling them removes the config for it in the conf files. Its how I can test failover since nothing answers the requests


(United Kingdom) #6

Many thanks everybody! The fwconsole stop command most certainly takes the sip channel down - or at least portqry says that port 5060 udp is down anyway. We still need to test, but this at least gives me somewhere to start. Thanks again!

Steve


(United Kingdom) #7

Hi everybody, FYI, just tested fwconsole stop today and it works a treat. Soon as the command was run the calls came flooding in to the secondary.

Thanks again!


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.