How to fix? IP Trunks Online not working since router reboot

Latest distro, Asterisk 11

I am registered at Flowroute and sip peer phones show up, I re-booted router, now IP Trunks Online shows 0.

It says Host Unspecified, I am not sure what or where to set that, it was all working fine before I rebooted the router, I did not change anything in Freepbx.

How do I fix that? Thank you.

sip show peers
100/100 XX.XX.XX.X D A 5064 OK (35 ms)
flowroute/XXXXXXXX (Unspecified) N 0 Unknown

sip show registry
Host dnsmgr Username Refresh State Reg.Time N XXXXXXXX 105 Registered Thu, 28 Nov 2013 18:20:28
1 SIP registrations.

sip show settings
Global Settings:

UDP Bindaddress:
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: Off
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-2.11.0(11.4.0)
SDP Session Name: Asterisk PBX 11.4.0
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: No
Send RPID: No
Legacy userfield parse: No
Send Diversion: Yes
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: Off
Auth. Failure Events: Off
T.38 support: Yes
T.38 EC mode: Redundancy
T.38 MaxDtgrm: 400
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No

Network QoS Settings:

IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Enabled using externaddr
Externaddr: XX.XXX.XX.XX:0
Externrefresh: 10
Localnet: XX.XX.XX.X/

Global Signalling Settings:

Codecs: (ulaw|g729)
Codec Order: g729:20,ulaw:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: Yes
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 30
RTP Hold Timeout: 300
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Sub. min duration 60 secs
Sub. max duration: 3600 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Originate
Session Refresher: uas
Session Expires: 1200 secs
Session Min-SE: 300 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Record on feature: automon
Record off feature: automon
Force rport: Yes
DTMF: rfc2833
Qualify: 0
Keepalive: 0
Use ClientCode: No
Progress inband: Never
Tone zone:
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97

Before I rebooted the router, I did a poweroff on the freepbx server. I restarted the server after the router restarted. I had the Trunk Online issue. For some reason, I duplicated the trunk, which caused a reload, and then it worked. I have no idea why.

I was having this issue this morning, my trunks registered but weren’t online. I did the same, duplicated the trunk (which forced a reload) and the problem was solved. Weird.

Hope this helps someone else one day.

You know you could really save yourself some time if you learned a few Asterisk commands. ‘sip reload’ would have taken care of this.

Brilliant! Thanks for the help!