How To Disable Music On Hold : Please Help

Hello All,

I searched everywhere without success. I am trying to disable MOH. Any help would be greatly appreciated.


The music on hold configuration is in:


If you open this file I believe you can comment out the line which points to the MOH music file directory.
Just put a semicolon “;” in front of the line(s) that begin with “directory”.

Restart asterisk and I think you’ll have no more MOH.


thank you much for your quick reply - i will give it a shot

Let me know if it works…


hey bill - i deleted the default WAV files and uploaded a song (to test different things before i used your method)- when i did that, the music on hold went away (i think) - when i put someone on hold, there is silence (which is what i was looking for) -but i would think that the song i uploaded would have played - i also noticed in the inbound/outbound trunks, (GUI) there is an option to put the MOH to “none” - that may work, although i couldnt test it because i cant seem to get music to play now - i tried uploading 2 different songs one MP3 one WAV - i couldnt resort back to the default music because i deleted them - the only thing i can think is that there may be a volume control somewhere i need to adjust - anyway, im not going to spend anymore time on it right now - i accomplished what i was looking for (even if it was luck) - i do appreciate your help … eventually, i will get back to it because i dont like to “rig” anything - i just dont have the time now -

-as for anyone trying to upload songs - make sure that there are NO spaces in the file title - if there are, you wont be able to upload it - not sure why this is…so be sure to rename your music file with NO spaces

Need to make sure the music files are properly sampled…8 khz…I believe. I think the no MOH ticks only affects the trunks, not internal calls. Been a while since I fooled with MOH, but you should be able to get the MOH sample rates by googleing it.