How to Configure missedcallnotify Module

I recently downloaded and installed the module labeled ‘missedcallnotify’ from here: http://www.freepbx.org/trac/browser/contributed_modules/modules/missedcallnotify on my 2.10 system running asterisk 1.8.x, but after installing the module, I can’t find a configuration page.

Upon further inspection of the module, it appears that there isn’t a config ‘page’ for this module. So, how do I enable it?

I have already tested the ‘mail’ function at the command line, which is working. I have also checked the freebpx logs to see if there was anything being logged during the ‘missed’ test calls. Unfortunately, I can’t find anything.

Does anyone know what you need to do after installing the module in the module admin?

There should be a new sub-section in the Extensions page that allows you to enable notifications on a per extension basis.

That’s what I was expecting. Unfortunately, that’s not what I see on my screen.

I decided to uninstall the module and re-install it. Still, I can’t see anything. I decided to attach screenshots.

http://noscasa.com/bruce/Devices.png
http://noscasa.com/bruce/Extension-Users.png

Like most advanced settings you need to add the device first then it will show up.

I’ll give this a try later this evening when I return home from work. Is it true that I need to be running v2.11 in order for this feature to be available? Moreover, does my asterisk v1.8.x need to be upgraded to v10+ since I noticed in that changelog, some sort of missed call support was included?

I can confirm that the GUI elements work on FreePBX 2.11, your issue may be related to the fact that you are running freepbx 2.10. Buried in the inline comments in functions.inc.php is this line:

Method fpr splicing using modified splice code yet not implemented in 2.10.0.2

I tried creating a new device first and then a new user, but the extra settings didn’t appear after doing so. Does anyone have a screenshot showing me where I should expect to see the added settings?

I saw that also the other day, but I discounted that as being a ‘cause’ to my dilemma because there’s an ‘else’ clause there which executes some custom splicing if users are using 2.10.

Hopefully you can see this:

I can confirm that the GUI elements show up in FreePBX ver. 2.10.1.5

Thank you. I was able to see your screenshot and I saw the GUI elements. I’m running FreePBX 2.10.1.9. Are you running Device and User mode like me?

Negative, I’m not running D&U.

Perhaps that module is not compatible with D&U mode. Does anyone else have it working on a non D&U system?

The module probably wasn’t written for device and user mode and there’s no way to get around that except having TSM (the developer) code it for that. It will be two different ways to code and the original developer probably didn’t account for device and user mode (most dont).

The splice hack is for the splice dial plan generator in freepbx. It has nothing to do with the gui.

Hi,

you have to change something in the Module function.inc.php from the tar.gz archive.

Under function missedcallnotify_configpageinit($pagename)
you must change extension to users.

// We only want to hook ‘users’ or ‘extensions’ pages.
if ($pagename != ‘users’)
return true;

I tried following your link, but no dice. I tried logging in with my username/pass combo and I’m told I am not allowed to login there…??? What gives?

Is there a way to be notified if there is a missed call on the trunk?

Meaning, this notification will notify an extension if it missed the call, but what if someone else in the ring group picks it up?

I’ve installed the module but I’m getting this error :

ExecIf((“SIP/XXXXXX30-0000015b”, "0?System(echo “” | mail -s “MissedCallGroup (602) - XXXXXXX430 " )”) in new stack

[2014-02-06 17:38:31] WARNING[25732][C-0000017c]: pbx.c:1618 pbx_exec: The application delimiter is now the comma, not the pipe. Did you forget to convert your dialplan? (ExecIf(0?System(echo “” | mail -s "MissedCallGroup (602) - XXXXX430 " )))

Any recommendation is appreciated.

Thank you
Iossi

I set it up on an extension, and I am not getting the missed call notifications even tough it seems like it is trying to sent it out, I get:

Executing [[email protected]:1] ExecIf(“SIP/-Ji--0000a0de", "0?System(echo “” | mail -s "MissedCall (410) - "MRLG:"COMPUTER NETWOR <9097>" comp[email protected])") in new stack
– Executing [[email protected]:2] ExecIf("SIP/Aray
n-Ji
l-0000a0de", "0?System(echo “” | mail -s "MissedCallGroup () - "MRLG:"COMPUTER NETWOR <9097***75>” )") in new stack

Any ideas?

I found that I had this installed but not enabled, and I tried enabling it, but I did not activate it from any extensions. By watching the Asterisk CLI during an incoming call I saw that it still attempts to send an email even when there is no email address filled in for any of the extensions. Worse yet, it uses a System call rather than TrySystem, so when the mail function hangs because it can’t send an email with no address, the entire hangup routine grinds to a halt at that point.

Neither of those things should happen - it should not be trying to send an email when the email address field is blank, and it should be using TrySystem rather than System when sending the mail, so that the mail send attempt can’t halt or delay the call flow. My fear is that this could create some kind of “zombie” process that if repeated often enough could cause system resource issues.

So, I wanted to see if I could find a newer version of this module and found this thread, but the link at the top no longer works. It appears to throw you into the bug tracking system. Do you know if there is a newer link where I could get the compressed module file so I can upload it manually?

Also, where could someone could file a bug report on this module, since it’s not officially a part of FreePBX?

You can file it on our tracker but I dont think TSM will be able to get to it. The latest version was 0.5