How to config IVR with hours office closed


(Pinzypbx) #1

Hello, (freepbx on raspberry pi) Current Asterisk Version: 11.21.0

I have this problem, I have set in freePBX raspberry the IVR with vocal message, and I set in inbound destination the IVR.
This work correctly, But I don’t able to se the same IVR when my office are closed with other vocal message.

Please Help Me, I see the different guide with Time condition e Time Group but not work correctly or I not set well.

Thanks in advance at all


(Serge Adam) #2

Create an IVR. Call it “Open”. Set it to what you want to say when you are open.
Create an IVR. Call it Closed. Set it to what you want to say when you are closed.
Create a Time Group. Call it “Open”. Set your open times: M-F 0900-1700
Create a Time Condition. Call it Open. Set when it matches to the “Open” IVR. Set when no match to the “Closed” IVR
Change your inbound route to go to the “Open” Time Condition.


(Pinzypbx) #3

Hello,

thx for you reply, I set like your config but freepbx send this similar vocal message:

you have not service dialog… please try again

:frowning:


(Pinzypbx) #4

So I retry and work correctly for IVR open, but when is after 17:00 or 5pm the IVR closed not work, the vocal message is ever of IVR open.

:frowning:


(Pinzypbx) #5

ok solved, the problem was the name file of audio recorded, so with out symbol - , " _ and withou “space” the audio was reproduced and work correctly.


(Dave Burgess) #6

I think this would warrant a ticket.

The file name is entered on the screen name, so making sure that spaces aren’t part of the name would be a good thing for FreePBX to check. Of course, the simplest solution is a “no spaces in the file name” note on the screen, but there are programmatic solutions that might save someone else some angst later.


(Andrew Nagy) #7

Except it’s not an issue in 13


#8

Thank you for the tip, this works perfectly on my setup! :wink:
(FreePBX 13.0.192.19)


(Mikelovell) #9

i have done this exact setup as directed, but people can still call outside of biz hours. its driving me nuts :frowning: anyone able to help ?


(Dave Burgess) #10

You started with a 5 year old post, so I doubt it’s exactly the same thing. What are you actually doing? Have you posted any logs? What options are you choosing?

“It doesn’t work” is not even close to sufficient to let us help you. we need more details, like what you’re doing, what’s not working, and what the system is actually doing when.


(Mikelovell) #11

im trying to setup out of hours so the phones dont ring before business hours 9am to 5pm. i followed the above directions 100% yet no matter what i try, and ive tried all options i can think of or that look logical, customers can still phone in before 9am.


(Itzik) #12

Ensure that the time is correct on your system.

If it is correct, and still not working, please create a new thread and post a pastebin link that contains a call trace.

Instructions: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII